Opened 7 years ago

Closed 7 years ago

#43076 closed defect (fixed)

Swig version error using Dolfin

Reported by: mwathen@… Owned by: seanfarley (Sean Farley)
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc:
Port: py-ffc

Description (last modified by seanfarley (Sean Farley))

I updated macports today and it installed the new version of swig. Unfortunately other libraries that I'm using depend on the the previous version but I'm not sure how to go back to this one. Here is the error I get when running my python script

Traceback (most recent call last):
  File "../FEniCS/PoissonExample/poisson.py", line 45, in <module>
    f = Expression("(pow(x[0]-0.5,2)-4*pow(x[1]-0.5,4))")
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/dolfin/functions/expression.py", line 582, in __new__
    [generic_function_members])
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/dolfin/compilemodules/expressions.py", line 217, in compile_expressions
    additional_declarations))
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/dolfin/compilemodules/expressions.py", line 142, in compile_expression_code
    code, additional_declarations=additional_declarations)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/dolfin/compilemodules/jit.py", line 60, in mpi_jit
    return local_jit(*args, **kwargs)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/dolfin/compilemodules/compilemodule.py", line 406, in compile_extension_module
    check_swig_version(compiled_module)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/dolfin/compilemodules/compilemodule.py", line 252, in check_swig_version
    (cpp.__swigversion__, compiled_module.swigversion))
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/dolfin/cpp/common.py", line 2296, in dolfin_error
    return _common.dolfin_error(*args)
RuntimeError: 

*** -------------------------------------------------------------------------
*** DOLFIN encountered an error. If you are not able to resolve this issue
*** using the information listed below, you can ask for help at
***
***     fenics@fenicsproject.org
***
*** Remember to include the error message listed below and, if possible,
*** include a *minimal* running example to reproduce the error.
***
*** -------------------------------------------------------------------------
*** Error:   Unable to compiling extension module.
*** Reason:  Incompatible swig versions detected. DOLFIN swig version is not the same as extension module swig version: '2.0.11' != '3.0.0' .
*** Where:   This error was encountered inside compilemodule.py.
*** Process: 0
*** 
*** DOLFIN version: 1.3.0
*** Git changeset:  
*** -------------------------------------------------------------------------

Change History (7)

comment:1 Changed 7 years ago by seanfarley (Sean Farley)

Description: modified (diff)
Owner: changed from macports-tickets@… to sean@…
Status: newassigned

comment:2 Changed 7 years ago by seanfarley (Sean Farley)

Looks like the FEniCS ports need to be rev bumped. If someone else can test this, please do so since I might not get to this tonight.

comment:3 in reply to:  2 Changed 7 years ago by mwathen@…

Replying to sean@…:

Looks like the FEniCS ports need to be rev bumped. If someone else can test this, please do so since I might not get to this tonight.

Are there any other outputs that you need to be able to fix this?

Last edited 7 years ago by mwathen@… (previous) (diff)

comment:4 Changed 7 years ago by mf2k (Frank Schima)

Port: py-ffc added

comment:5 in reply to:  4 ; Changed 7 years ago by mwathen@…

Replying to macsforever2000@…:

What do you mean by set to py-ffc?

comment:6 in reply to:  5 Changed 7 years ago by seanfarley (Sean Farley)

Replying to mwathen@…:

Replying to macsforever2000@…:

What do you mean by set to py-ffc?

It was just a hint for other macports devs.

comment:7 Changed 7 years ago by seanfarley (Sean Farley)

Resolution: fixed
Status: assignedclosed

Fixed in r118781. Thanks for the report!

Note: See TracTickets for help on using tickets.