Opened 7 years ago

Closed 7 years ago

#43081 closed defect (invalid)

openssl @1.0.1f: error: ‘Dl_info’ undeclared (first use in this function)

Reported by: exafs@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc: mww@…, ryandesign (Ryan Schmidt)
Port: openssl

Description (last modified by ryandesign (Ryan Schmidt))

Tiger 10.4.11 ppc on 400 MHz ppc

:msg:main --->  Dependencies to be installed: openssl
:debug:main Starting logging for openssl
:error:build The following dependencies were not installed: openssl

Attachments (2)

main.log (125.4 KB) - added by exafs@… 7 years ago.
Neil's iMac.txt (1.2 MB) - added by exafs@… 7 years ago.

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by exafs@…

Attachment: main.log added

Changed 7 years ago by exafs@…

Attachment: Neil's iMac.txt added

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: mww@… ryandesign@… added
Description: modified (diff)
Port: openssl added
Resolution: invalid
Status: newclosed
Summary: openssl @2.2.1 build failureopenssl @1.0.1f: error: ‘Dl_info’ undeclared (first use in this function)

The log says:

:info:build dso_dlfcn.c: In function ‘dlfcn_pathbyaddr’:
:info:build dso_dlfcn.c:447: error: ‘Dl_info’ undeclared (first use in this function)
:info:build dso_dlfcn.c:447: error: (Each undeclared identifier is reported only once
:info:build dso_dlfcn.c:447: error: for each function it appears in.)
:info:build dso_dlfcn.c:447: error: parse error before ‘dli’
:info:build dso_dlfcn.c:457: error: ‘dli’ undeclared (first use in this function)

Duplicate of #33177. See my explanation there of how to solve it.

Note: See TracTickets for help on using tickets.