Opened 6 years ago

Closed 6 years ago

#43091 closed defect (fixed)

py27-matplotlib @1.3.1_4: +gtk3 variant missing dependency on gtk3

Reported by: mndavidoff (Monte Davidoff) Owned by: seanfarley (Sean Farley)
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: haspatch Cc: petrrr
Port: py-matplotlib

Description

Installing py-matplotlib +gtk3 fails if the gtk3 port is not installed.

$ port installed gtk3
None of the specified ports are installed.
$ sudo port -vs install py27-matplotlib +gtk3
...
--->  Building py27-matplotlib
...
OPTIONAL BACKEND EXTENSIONS
...
               gtk3agg: no  [Requires gtk3 development files to be
                        installed.]
...
============================================================================
                        * The following required packages can not be built:
                        * gtk3agg
Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_python_py-matplotlib/py27-matplotlib/work/matplotlib-1.3.1" && /opt/local/Library/Frameworks/Python.framework/Versions/2.7/bin/python2.7 setup.py --no-user-cfg build 
Exit code: 1
Error: org.macports.build for port py27-matplotlib returned: command execution failed
Warning: targets not executed for py27-matplotlib: org.macports.activate org.macports.build org.macports.destroot org.macports.install
Please see the log file for port py27-matplotlib for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_python_py-matplotlib/py27-matplotlib/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port py27-matplotlib failed

The attached patch fixes the problem.

Attachments (2)

main.log.gz (6.5 KB) - added by mndavidoff (Monte Davidoff) 6 years ago.
Portfile.diff (489 bytes) - added by mndavidoff (Monte Davidoff) 6 years ago.

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by mndavidoff (Monte Davidoff)

Attachment: main.log.gz added

Changed 6 years ago by mndavidoff (Monte Davidoff)

Attachment: Portfile.diff added

comment:1 Changed 6 years ago by petrrr

Cc: Peter.Danecek@… added

Cc Me!

comment:2 Changed 6 years ago by mf2k (Frank Schima)

Cc: sean@… removed
Owner: changed from macports-tickets@… to sean@…

comment:3 Changed 6 years ago by petrrr

This looks like a duplicate of #42918. I apparently was able to build on py27, because the dependency was already in place.

comment:4 Changed 6 years ago by seanfarley (Sean Farley)

Resolution: fixed
Status: newclosed

Fixed in r118778. Thanks for the report!

Note: See TracTickets for help on using tickets.