Opened 6 years ago

Closed 6 years ago

#43102 closed defect (fixed)

py27-pyqt4 and py27-sip not aligned

Reported by: tommaso.vinci@… Owned by: michaelld (Michael Dickens)
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc: petrrr
Port: py-pyqt4

Description

There have been major changes in sip (i.e. pyqtconfig almost removed) and pyqt should be aligned with sip.

I'm in a situation in which I should use both and since they're not aligned things breaks up:

RuntimeError: the sip module implements API v11.0 but the PyQt4.QtCore module requires API v10.1

This must be fixed before upgrading the package py27-qscintilla which uses both pyqt and sip for c++/python bindings

Change History (5)

comment:1 Changed 6 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to michaelld@…
Port: py-pyqt4 added; py27-pyqt4 removed

In the future, please Cc the port maintainers (port info --maintainers py27-pyqt4).

comment:2 Changed 6 years ago by michaelld (Michael Dickens)

You most likely need to update SIP (should be at 4.15.5_0):

sudo port selfupdate
sudo port upgrade outdated

and py*-sip should be part of the update. If that does not work, please attach the output of "port installed active".

comment:3 Changed 6 years ago by petrrr

Cc: Peter.Danecek@… added

Cc Me!

comment:4 Changed 6 years ago by michaelld (Michael Dickens)

BTW> pyqt4 4.10.4_1 matches API (for me) with sip 4.15.5_0. These versions are current as installed by MacPorts, which is why I believe you just need to selfupdate MacPorts then do "update outdated".

comment:5 Changed 6 years ago by michaelld (Michael Dickens)

Resolution: fixed
Status: newclosed

I'm closing this ticket as fixed, since both SIP and PyQt4 have been updated since then; and, their API versions match.

Note: See TracTickets for help on using tickets.