Opened 6 years ago

Closed 6 years ago

#43104 closed defect (duplicate)

webkit-gtk build fails in configure - missing gtk+-x11-2.0

Reported by: Polyergic (Shad Sterling) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc: jeremyhu (Jeremy Huddleston Sequoia), dbevans (David B. Evans)
Port: webkit-gtk

Description

Looks like it's expecting a port named "gtk+-x11-2.0"

:info:configure checking for GTK_X11... no
:info:configure configure: error: Package requirements (gtk+-x11-2.0 = 2.24.23) were not met:
:info:configure 
:info:configure No package 'gtk+-x11-2.0' found

OS X 10.9.2, selfupdate run this morning, upgrade outdated was interrupted by this error

Attachments (1)

main.log (207.7 KB) - added by Polyergic (Shad Sterling) 6 years ago.

Download all attachments as: .zip

Change History (2)

Changed 6 years ago by Polyergic (Shad Sterling)

Attachment: main.log added

comment:1 in reply to:  description Changed 6 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Replying to me@…:

Looks like it's expecting a port named "gtk+-x11-2.0"

No, it's expecting a pkg-config entry by that name. Presumably you are using the quartz variant of gtk2 instead of the x11 variant. Duplicate of #43103.

Note: See TracTickets for help on using tickets.