Opened 6 years ago

Closed 6 years ago

#43106 closed defect (duplicate)

ShiftIt: fatal error: 'X11/Xlib.h' file not found

Reported by: otto.julio@… Owned by: phw@…
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc:
Port: ShiftIt

Description (last modified by ryandesign (Ryan Schmidt))

The following error appears when building the ShiftIt on 10.9 Mavericks:

X11Utils.c:22:10: fatal error: 'X11/Xlib.h' file not found.

Build log is attached.

Attachments (1)

main.log (148.3 KB) - added by otto.julio@… 6 years ago.
build log

Download all attachments as: .zip

Change History (3)

Changed 6 years ago by otto.julio@…

Attachment: main.log added

build log

comment:1 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: phw@… openmaintainer@… removed
Description: modified (diff)
Owner: changed from macports-tickets@… to phw@…

How strange. ShiftIt does declare a dependency on the xorg-libX11 port that provides that file, and your log shows it is installed. However, I see there is no -I/opt/local/include being used; maybe that's the problem.

comment:2 Changed 6 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed
Summary: ShiftIt fails to build on 10.9 MavericksShiftIt: fatal error: 'X11/Xlib.h' file not found

Duplicate of #37110.

Note: See TracTickets for help on using tickets.