Opened 9 years ago

Last modified 7 years ago

#43225 new submission

[new] rb-vagrant

Reported by: jul_bsd@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: cooljeanius (Eric Gallager), seh@…
Port: rb-vagrant

Description

tool for building and distributing working environments

  • basic Portfile
  • need udate rb19-bundler
  • please review build process w bundler and rake, not sure if there is any Portgroup in this case

Attachments (1)

Portfile (1.5 KB) - added by jul_bsd@… 9 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 9 years ago by mf2k (Frank Schima)

Keywords: haspatch removed

comment:2 Changed 9 years ago by cooljeanius (Eric Gallager)

I had actually started work on my own copy of a Portfile for vagrant, but never got it working well enough to submit: https://github.com/cooljeanius/LocalPorts/blob/master/ruby/rb-vagrant/Portfile

Differences I have noticed between our Portfiles:

  • my ruby.setup line remains un-commented-out, so I assume that that means that it works:
    ruby.setup          vagrant 1.0.7 gem {} rubygems
    
  • I use categories-append instead of just categories because the ruby portgroup already adds the ruby category by default. Also the categories that I append are devel and emulators instead of sysutils, but I guess that is mostly just a matter of personal preference...
  • You wrote your port after the rb19-rake port was added, and as such were able to work around the whole issue of using multiple versions of ruby that I was running into... although if this port is now using the ruby from the ruby19 port, it should probably be now called rb19-vagrant instead of just rb-vagrant...
  • I just kept the default build and destroot behavior from the ruby portgroup, but that is because I am installing it from the gem, and you are getting it directly from the sources on GitHub, which I only do for testing.
  • I used a bin:-style dependency for VirtualBox, because VirtualBox drags in qt4-mac, which is humongous, and VirtualBox is also humongous in its own right. Using a bin:-style dependency allows me to just use the binary installer from the VirtualBox website if I am in too much of a hurry to compile all of its dependencies with MacPorts.
  • Your Portfile is for a newer version of vagrant than mine, so maybe some stuff has been fixed upstream since I last tried it...
  • I tried finding MacPorts equivalents for all of the dependencies that had been listed on Vagrant's rubygems page when I had been working on it, but it looks like most of those dependencies have been dropped with the current version of Vagrant...

comment:3 Changed 9 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:4 Changed 9 years ago by jul_bsd@…

Cool! For now I didn't do much as it needs an updated bundler (#43224 - not working for now). There is also docker in the same kind I'm interested in but it would be a go compiler group which I'm not sure there is. I set rake and bundler stuff but I don't know if there is a preferred way for macports and couldn't test it because of bundler but documentation says it installs like this.

comment:5 Changed 9 years ago by jul_bsd@…

bump 1.6.2

Changed 9 years ago by jul_bsd@…

Attachment: Portfile added

comment:6 Changed 7 years ago by seh@…

Cc: seh@… added

Cc Me!

Note: See TracTickets for help on using tickets.