Opened 5 years ago

Closed 5 years ago

#43264 closed defect (fixed)

grace@5.1.23: crashes with SIGSYS on mavericks

Reported by: slabrosse@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: mavericks haspatch Cc: mlund@…, cooljeanius (Eric Gallager), varadharajan.srinivasan@…, ryandesign (Ryan Schmidt)
Port: grace

Description (last modified by ryandesign (Ryan Schmidt))

I just installed macports (2.2.1) on a new machine running under mavericks (10.9.2) and the first port I installed, grace (@5.1.23), does not work. It launches the window but immediately crashes with the following message :

xmgrace 

Oops! Got SIGSYS

Please use "Help/Comments" to report the bug.
Abort trap: 6

I tried to launch the app from both a terminal and a xterm with the exact same result. I run grace on another machine with mavericks but this machine was upgraded and uses an older version of macports and grace. Thanks for your help...

Stephane

Attachments (1)

Portfile-grace.diff (420 bytes) - added by mlund@… 5 years ago.
Portfile patch

Download all attachments as: .zip

Change History (11)

comment:1 Changed 5 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: grace removed
Milestone: MacPorts 2.3.0
Port: grace added; grace@5.1.23 removed
Summary: grace crashes with SIGSYS on mavericksgrace@5.1.23: crashes with SIGSYS on mavericks

Sorry, the grace port has no maintainer right now. You should contact the developers of grace directly.

comment:2 Changed 5 years ago by mlund@…

Cc: mlund@… added

Cc Me! I've had the same problem on several new installs.

Last edited 5 years ago by mlund@… (previous) (diff)

comment:3 Changed 5 years ago by mlund@…

Could the problem be related to clang as described here:

https://github.com/Homebrew/homebrew/issues/27840

comment:4 Changed 5 years ago by mlund@…

Building grace 5.1.23 from source outside macports, the following gives the SIGSYS failure

LDFLAGS=-L/opt/local/lib CPPFLAGS="-O2 -I/opt/local/include/" ./configure

while

LDFLAGS=-L/opt/local/lib CPPFLAGS="-O1 -I/opt/local/include/" ./configure

works fine (Mavericks, 10.9.2). While this could be an easy fix for the port, proper debugging would be better.

Changed 5 years ago by mlund@…

Attachment: Portfile-grace.diff added

Portfile patch

comment:5 Changed 5 years ago by ryandesign (Ryan Schmidt)

Duplicate #43288 has the same patch but additionally increases the revision, which is indeed necessary since this is a runtime failure.

comment:6 Changed 5 years ago by ryandesign (Ryan Schmidt)

Keywords: haspatch added

comment:7 Changed 5 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:8 Changed 5 years ago by ryandesign (Ryan Schmidt)

Cc: varadharajan.srinivasan@… added

Has duplicate #43782.

comment:9 Changed 5 years ago by ryandesign (Ryan Schmidt)

Hmm, I can't reproduce this. I just built grace in MacPorts on Mavericks and it does not crash for me. I tried using Xcode 5.1.1's clang 3.4svn, MacPorts' clang 3.4 and 3.3, and I tried setting configure.optflags to -O2 (the default is -Os); nothing makes it crash for me.

There is no MacPorts maintainer of grace. You should report this problem to the developers of grace for assistance.

comment:10 Changed 5 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Resolution: fixed
Status: newclosed

In the meantime, I've committed the patch that reduces the optimization level, since that was reported to help.

Note: See TracTickets for help on using tickets.