Opened 7 years ago

Closed 7 years ago

#43305 closed defect (invalid)

Upgrade OpenSSL Not Working

Reported by: anthrotech@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc:
Port: openssl

Description (last modified by ci42)

When I try to upgrade openssl (sudo upgrade openssl), I get the following message:

--->  Scanning binaries for linking errors: 100.0%
--->  No broken files found.

openssl not updated. Still at @1.0.1f_0.

I have tried to deactivate and uninstall openssl, but there are too many dependencies.

How can I upgrade to openssl @1.0.1g without uninstalling everything and installing ports agin.

Brew is looking better everyday. :(

I am using Macports version: MacPorts 2.2.1.

I did run selfupdate yesterday.

Any suggestions would be great.

Change History (3)

comment:1 Changed 7 years ago by ci42

Description: modified (diff)
Keywords: upgrade not working removed
Priority: HighNormal

Please run selfupdate and clean first:

$ sudo port selfupdate
$ sudo port clean openssl
$ sudo port upgrade openssl

If that doesn't work please provide the output of:

$ port info openssl
$ sudo port -d sync

Please note that priority high is reserved for MacPorts team members and don't use arbitrary keywords (see DraftKeywordGuidelines).

comment:2 Changed 7 years ago by anthrotech@…

Thank you. The first set of commands worked. I appreciate the heads-up with running selfupdate first again and then the clean and upgrade commands. Worked like a charm.

Sorry for the ambiguous keywords and priority level.

comment:3 Changed 7 years ago by ci42

Resolution: invalid
Status: newclosed

Glad you got it working.

Note: See TracTickets for help on using tickets.