Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#43548 closed defect (duplicate)

zmq +pgm @3.2.4 fails build on conflicting group_req / group_source_req definitions

Reported by: posita (Matt Bogosian (formerly @mbogosian)) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc: merijn (Merijn Verstraaten)
Port: zmq

Description

Log attached. Pertinent part:

...

:info:build ./include/pgm/in.h:33:8: error: redefinition of 'group_req'
:info:build In file included from thread.c:23:
:info:build In file included from ./include/impl/framework.h:66:
:info:build In file included from ./include/impl/notify.h:46:
:info:build In file included from ./include/impl/sockaddr.h:38:
:info:build ./include/pgm/in.h:33:8: error: ./include/impl/framework.h:66:
:info:build In file included from redefinition of 'group_req'./include/impl/notify.h
:info:build :46:
:info:build struct group_req
:info:build        ^
:info:build struct group_req
:info:build        ^
:info:build /usr/include/netinet/in.h:531:8: note: previous definition is here
:info:build struct group_req {
:info:build        ^/usr/include/netinet/in.h:In file included from ./include/impl/sockaddr.h:531:
:info:build 38:
:info:build ./include/pgm/in.h:33:8: error: redefinition of 'group_req'
:info:build In file included from list.c:22:
:info:build In file included from ./include/impl/framework.h:66:
:info:build In file included from ./include/impl/notify.hstruct group_req:
:info:build        ^
:info:build 8: note: previous definition is here
:info:build struct group_req {
:info:build        ^
:info:build /usr/include/netinet/in.h:531:8In file included from thread.c:23: note: :
:info:build previous definition is hereIn file included from 
:info:build ./include/impl/framework.h:66:
:info:build In file included from ./include/impl/notify.h:46:
:info:build In file included from ./include/impl/sockaddr.hstruct group_req {
:info:build 46       ^
:info:build :38:
:info:build ./include/pgm/in.h:39:8: error: redefinition of 'group_source_req'
:info:build struct group_source_req
:info:build        ^
:info:build In file included from mem.c:28/usr/include/netinet/in.h:536:
:info:build In file included from :
:info:build ./include/impl/sockaddr.hIn file included from :38./include/impl/framework.h:
:info:build :./include/pgm/in.h::866:
:info:build 39In file included from :./include/impl/notify.h:: note: 468: error: redefinition of 'group_source_req'
:info:build struct group_source_req
:info:build        ^
:info:build /usr/include/netinet/in.h:536:8: note: previous definition is here
:info:build struct group_source_req {:
:info:build In file included from previous definition is here./include/impl/sockaddr.h:38
:info:build        ^
:info:build :
:info:build ./include/pgm/in.h:39:8: 
:info:build struct group_source_req {
:info:build        ^
:info:build error: redefinition of 'group_source_req'
:info:build struct group_source_req
:info:build        ^
:info:build /usr/include/netinet/in.h:536:8: note: previous definition is here
:info:build struct group_source_req {
:info:build        ^
:info:build In file included from string.c:29:
:info:build In file included from ./include/impl/framework.h:66:
:info:build In file included from ./include/impl/notify.h:46:
:info:build In file included from ./include/impl/sockaddr.h:38:
:info:build ./include/pgm/in.h:33:8: error: redefinition of 'group_req'
:info:build struct group_req
:info:build        ^
:info:build /usr/include/netinet/in.h:531:8: note: previous definition is here
:info:build struct group_req {
:info:build        ^
:info:build In file included from string.c:29:
:info:build In file included from ./include/impl/framework.h:66:
:info:build In file included from ./include/impl/notify.h:46:
:info:build In file included from ./include/impl/sockaddr.h:38:
:info:build ./include/pgm/in.h:39:8: error: redefinition of 'group_source_req'
:info:build struct group_source_req
:info:build        ^
:info:build /usr/include/netinet/in.h:536:8: note: previous definition is here
:info:build struct group_source_req {
:info:build        ^

...

Attachments (1)

zero_pgm_main.log (58.2 KB) - added by posita (Matt Bogosian (formerly @mbogosian)) 7 years ago.

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by posita (Matt Bogosian (formerly @mbogosian))

Attachment: zero_pgm_main.log added

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #36554.

comment:2 Changed 7 years ago by posita (Matt Bogosian (formerly @mbogosian))

Sorry, I totally missed that one in my search! :-$

Note: See TracTickets for help on using tickets.