Opened 6 years ago

Closed 5 years ago

#43589 closed defect (fixed)

libgnome: error: use of undeclared identifier 'g_threads_got_initialized'

Reported by: hannesdottir@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc:
Port: libgnome

Description (last modified by ryandesign (Ryan Schmidt))

Running a

$sudo port install meld

it fails installing libgnome. My machine is a MacBook, OS X 10.9.2, 2.9GHz Intel Core i7.

I attach the log file

Attachments (4)

main.log (27.8 KB) - added by hannesdottir@… 6 years ago.
log file
patch-libgnome-Makefile.am.diff (373 bytes) - added by order@… 6 years ago.
Missing patch file for Makefile.am
patch-libgnome-Makefile.in.diff (375 bytes) - added by order@… 6 years ago.
Corrected Makefile.in patchfile
Portfile (1.5 KB) - added by order@… 6 years ago.
Corrected portfile

Download all attachments as: .zip

Change History (9)

Changed 6 years ago by hannesdottir@…

Attachment: main.log added

log file

comment:1 Changed 6 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Port: libgnome added
Summary: When installing meld: Error: Failed to install libgnomelibgnome: error: use of undeclared identifier 'g_threads_got_initialized'

comment:2 Changed 6 years ago by paulccobb@…

I ran into this problem too, and found a change that seems relevant posted to the gnome git repository for libgnome-2.32.1 In a nutshell, the tweak is simply to remove -DG_DISABLE_DEPRECATED from the Makefile. The commit report, such as it is, can be viewed at:

https://git.gnome.org/browse/libgnome/commit/?id=64a0443e26a50745c8fdc02eddf60985a977275f

I confirmed that with this change, the build of libgnome runs to completion on my system: PowerBook G4, Mac OS 10.5.8, XCode 3.1.4

I think this fixes the bug as described in this ticket, BUT I don't know any of the story with the deprecated code that gets enabled by this change - so the libgnome that gets built may contain broken things that I just haven't tripped over yet. I'm posting this info in case it's helpful (a) to anyone stuck on the same issue, or (b) to anyone looking into the ticket.

comment:3 Changed 6 years ago by order@…

There already is a patch (patch-libgnome-Makefile.in.diff) in MacPorts to get rid of the -DG_DISABLE_DEPRECATED flag. The problem seems to be that the patch does not have the correct line numbers for the Makefile. In addition, the Makefile.am also needs to be patched. After fixing the Makefile.in patch, adding the Makefile.am patch and adjusting the Portfile, it works for me.

It strikes me as odd that the patch command fails silently -- seems like a possibly serious problem.

Changed 6 years ago by order@…

Missing patch file for Makefile.am

Changed 6 years ago by order@…

Corrected Makefile.in patchfile

Changed 6 years ago by order@…

Attachment: Portfile added

Corrected portfile

comment:4 Changed 6 years ago by mf2k (Frank Schima)

@order: Per the guidelines, please instead attach a unified diff of the Portfile so we can easily see what changes you are proposing.

comment:5 Changed 5 years ago by dbevans (David B. Evans)

Resolution: fixed
Status: newclosed

libgnome build broken by my switch to autoreconf in r118282. Fixed (as indicated above) in r122755. Mea culpa.

Note: See TracTickets for help on using tickets.