Opened 6 years ago

Closed 6 years ago

#43642 closed defect (fixed)

tiff @4.0.3 - build hang

Reported by: burwell.cameron@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc: cooljeanius (Eric Gallager), ryandesign (Ryan Schmidt), mkae (Marko Käning), MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Port: tiff

Description

I'm trying to install geany on Mac OSX 10.9.2 Mavericks using the command 'sudo port install geany' and I get a hang on building tiff. I'm not sure if it's taking forever (I let it run literally all night - 7 hours) or if it's completely stuck. I've attached a text file containing my terminal's output when I try running the command.

Attachments (4)

tiff_hang (846 bytes) - added by burwell.cameron@… 6 years ago.
A text file containing my terminal's output
v_flag_output.txt (1.2 KB) - added by burwell.cameron@… 6 years ago.
sudo port -v install tiff
d_flag_output.txt (3.0 KB) - added by burwell.cameron@… 6 years ago.
sudo port -d install tiff
hang_output.txt (961 bytes) - added by burwell.cameron@… 6 years ago.
Similar hang output

Download all attachments as: .zip

Change History (20)

Changed 6 years ago by burwell.cameron@…

Attachment: tiff_hang added

A text file containing my terminal's output

comment:1 Changed 6 years ago by cooljeanius (Eric Gallager)

Try again with the -v or the -d flag so that it will print more messages so that you can see what is actually going on

comment:2 Changed 6 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:3 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Port: tiff added

tiff is not large; it doesn't take long to build. On my system (2.6 GHz quad core MacBook Pro) it takes only 2 minutes.

Your output shows that geany is already successfully installed, but that tiff is not linked correctly for some reason, and therefore MacPorts is trying to rebuild it. Knowing specifically why MacPorts thinks it's broken would be good to know, though it's not easy to get MacPorts to divulge that information. Perhaps the debug output Eric suggested you try above will be helpful.

Changed 6 years ago by burwell.cameron@…

Attachment: v_flag_output.txt added

sudo port -v install tiff

Changed 6 years ago by burwell.cameron@…

Attachment: d_flag_output.txt added

sudo port -d install tiff

Changed 6 years ago by burwell.cameron@…

Attachment: hang_output.txt added

Similar hang output

comment:4 Changed 6 years ago by burwell.cameron@…

Alright, so I did as you suggested and ran with the -d and -v flags, I will attach the parts I thought were relevant (unless you want me to pipe to a file, but it would be a very long one). It seems to be complaining about 7 broken files in particular (dynamic library, by the looks of it), and a broken port that I can't really make much sense of. However, the both had what I assume is a hang at one particular section of output and I put this in another text file that I will attach.

comment:5 Changed 6 years ago by ryandesign (Ryan Schmidt)

Ok, so the log at least shows us why MacPorts thinks tiff is broken:

Could not open /opt/X11/lib/libX11.6.dylib: Error opening or reading file (referenced from /opt/local/bin/tiffgt)

tiff is linked with a non-MacPorts version of X11 (probably Xquartz), and that non-MacPorts X11 was either uninstalled or upgraded to a version with a different library version, or for some other reason the library is no longer readable.

We don't want tiff (or anything) in MacPorts to use non-MacPorts X11, so this is a bug in the tiff port. In fact, the tiff port does not declare dependencies on any MacPorts X11 ports; these need to be added. Perhaps doing so will cure the hang you're experiencing.

comment:6 Changed 6 years ago by ryandesign (Ryan Schmidt)

Or, tiff needs to be made to not use X11. It looks like that was the intention before, but now (from my system):

configure: WARNING: unrecognized options: --with-apple-opengl-framework

So the option we were using to tell configure to use Apple's OpenGL framework is no longer recognized, so it's using the OpenGL libraries from the mesa port instead, which uses X11. We need to investigate how we can get tiff to use the OpenGL framework again.

comment:7 Changed 6 years ago by ryandesign (Ryan Schmidt)

Looks like we already noticed 2 years ago that that configure arg no longer works, but then we didn't remove it.

comment:8 Changed 6 years ago by burwell.cameron@…

Is there anything I can do to assist you on my end? I'm not really sure how I can set tiff's dependencies on my end.

comment:9 Changed 6 years ago by ryandesign (Ryan Schmidt)

Right, this is something we need to fix in the portfile. I spent some time looking into it earlier, but only reached the conclusion that the configure script checks first if libGL exists, and only if it doesn't does it check for the OpenGL framework; we want it to use the OpenGL framework regardless of whether any libGL is present, so we will have to fix the configure script, or figure out if we can influence its decisions by passing some more configure args.

comment:10 Changed 6 years ago by mkae (Marko Käning)

Cc: mk@… added

Cc Me!

comment:11 in reply to:  5 ; Changed 6 years ago by ryandesign (Ryan Schmidt)

Replying to ryandesign@…:

tiff is linked with a non-MacPorts version of X11 (probably Xquartz), and that non-MacPorts X11 was either uninstalled or upgraded to a version with a different library version, or for some other reason the library is no longer readable.

In fact, I've just found that the package we distribute from our packages server is linked in this incorrect way, so this problem would affect all the MacPorts users who use our packages but who don't have XQuartz installed.

comment:12 in reply to:  11 Changed 6 years ago by mkae (Marko Käning)

Replying to ryandesign@…:

In fact, I've just found that the package we distribute from our packages server is linked in this incorrect way, so this problem would affect all the MacPorts users who use our packages but who don't have XQuartz installed.

That's the case I ran into here. The Mavericks VM I was testing on indeed didn't have XQuartz installed.

comment:13 Changed 6 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

r120378 should prevent X11 OpenGL from being used.
Can anyone confirm?

comment:14 Changed 6 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Cc: mcalhoun@… added

Cc Me!

comment:15 in reply to:  13 Changed 6 years ago by dixiao@…

Replying to mcalhoun@…:

r120378 should prevent X11 OpenGL from being used.
Can anyone confirm?

I can confirm this fix the problem.

comment:16 Changed 6 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.