Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#43685 closed defect (worksforme)

gnuradio or grc command not found

Reported by: briansullivan2@… Owned by: michaelld (Michael Dickens)
Priority: Normal Milestone:
Component: ports Version: 2.2.1
Keywords: Cc: cooljeanius (Eric Gallager)
Port: gnuradio, gr-osmosdr

Description (last modified by ryandesign (Ryan Schmidt))

I had GQRX installed and working fine as well GNU Radio Companion, both installed from a .pkg(not using Macports) for a while I wanted to use the Osmosdr block in Gunuradio Companion and the only way to do this was via macports. I installed the gr-osmosdr port. Foolishly I made some other change regarding what I think was the environmental variables according to the instructions before conforming the new port installed and worked okay.

Before the macports install all I need to do to open GNURadio Companion was to type grc in terminal. Now I get "command not found" I don't know what changes I made exactly but I can tell you that env command gives me:

..TERM_PROGRAM=Apple_Terminal
SHELL=/bin/bash
TERM=xterm-256color
TMPDIR=/var/folders/_m/nwgn502d0zzf2xvy_frt8gqc0000gp/T/
Apple_PubSub_Socket_Render=/tmp/launch-W0grD9/Render
TERM_PROGRAM_VERSION=303.2
TERM_SESSION_ID=F4D140BD-3910-4C14-8B82-84E71A1DAF1D
USER=programming
COMMAND_MODE=unix2003
SSH_AUTH_SOCK=/tmp/launch-5lkR7I/Listeners
Apple_Ubiquity_Message=/tmp/launch-t9vkeh/Apple_Ubiquity_Message
__CF_USER_TEXT_ENCODING=0x1F6:0:0
PATH=/opt/local/bin:/opt/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/opt/X11/bin:/usr/X11/bin:/usr/local/git/bin:/opt/local/bin
PWD=/Users/programming
DBUS_LAUNCHD_SESSION_BUS_SOCKET=/tmp/launch-1bOS9C/unix_domain_listener
EDITOR=/user/bin/pico
LANG=en_US.UTF-8
HOME=/Users/programming
SHLVL=1
LOGNAME=programming
DISPLAY=/tmp/launch-uvktbH/org.macosforge.xquartz:0
_=/usr/bin/env
OLDPWD=/usr/libexec.

It's not the same as what the example in the instructions show, but I'm a bit of a NOOB and not sure how to interoperate this. This is what I have done so far to try to remedy the problem: install GNU Radio via macports, thinking that the gr-osomsdr port could not "talk" to GNU stuff installed via binary (osx traditional method) THEN uninstalled GQRX by dragging to the trash. THEN I tried uninstalling and reinstalling gnu radio with some different variants.

have tried this on three different macs iMac os x 10.7.5 MBP 10.9.2 and an MBA os x10.6.8(this last one was an effort on a clean os without Macports or gnu prior)

Your guidance is much appreciated.

Brian

Change History (5)

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: command not found environment variables bashrc removed
Owner: changed from macports-tickets@… to michaelld@…
Port: removed
Summary: gnuradio or grc command not fountgnuradio or grc command not found

comment:2 Changed 7 years ago by michaelld (Michael Dickens)

Resolution: worksforme
Status: newclosed

I'm really not sure what you're asking for here. That said, a while back you would type "grc" to get the GNU Radio Companion; maybe that's the binary executable version you had installed (somehow). That changed somewhere in 3.6 or thereabouts, to "gnuradio-companion". If you installed GNU Radio via MacPorts, then any of those ports will install "gnuradio-companion", not "grc". If this is not what you were asking for, then please email me directly "<michael.dickens@…>" and I'll help you through your issues; this does not seem to be a MacPorts issue.

comment:3 Changed 7 years ago by cooljeanius (Eric Gallager)

Also, if the binary were still called just grc, it would probably conflict with the grc port, which provides a different grc executable that is already experiencing a conflict with another port: #40143

comment:4 Changed 7 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:5 Changed 7 years ago by michaelld (Michael Dickens)

Interesting. I don't remember why "grc" was renamed, but a conflict with another executable seems like a very likely reason. "gnuradio-companion" is pretty unique.

Note: See TracTickets for help on using tickets.