Opened 7 years ago

Closed 7 years ago

#43817 closed defect (fixed)

dolfin: Could NOT find Eigen3 (missing: EIGEN3_INCLUDE_DIR EIGEN3_VERSION_OK)

Reported by: eld.khattatov@… Owned by: seanfarley (Sean Farley)
Priority: Normal Milestone:
Component: ports Version: 2.3.0
Keywords: Cc: seanfarley (Sean Farley)
Port: dolfin

Description

Trying to install dolfin on Mac OS X 10.9, it fails with the following error:

--->  Computing dependencies for dolfin
--->  Configuring dolfin
Error: org.macports.configure for port dolfin returned: configure failure: command execution failed
Please see the log file for port dolfin for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_dolfin/dolfin/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port dolfin failed
MacBook-Pro-Admin:~ admin$ sudo port clean dolfin
Password:
--->  Cleaning dolfin
MacBook-Pro-Admin:~ admin$ sudo port install dolfin
--->  Computing dependencies for dolfin
--->  Fetching archive for dolfin
--->  Attempting to fetch dolfin-1.3.0_2+mpich+parmetis+petsc+slepc+suitesparse.darwin_13.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/dolfin
--->  Attempting to fetch dolfin-1.3.0_2+mpich+parmetis+petsc+slepc+suitesparse.darwin_13.x86_64.tbz2 from http://packages.macports.org/dolfin
--->  Attempting to fetch dolfin-1.3.0_2+mpich+parmetis+petsc+slepc+suitesparse.darwin_13.x86_64.tbz2 from http://lil.fr.packages.macports.org/dolfin
--->  Fetching distfiles for dolfin
--->  Verifying checksums for dolfin
--->  Extracting dolfin
--->  Configuring dolfin
Error: org.macports.configure for port dolfin returned: configure failure: command execution failed
Please see the log file for port dolfin for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_dolfin/dolfin/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port dolfin failed

I have already port installed boost +mpich, updated the port tree. I read through the tickets #43496 and #42306, trying to follow the recommendations from them, however it still fails. Attached is the log file.

Attachments (1)

main.log (153.6 KB) - added by eld.khattatov@… 7 years ago.

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by eld.khattatov@…

Attachment: main.log added

comment:1 Changed 7 years ago by eld.khattatov@…

Cc: eld.khattatov@… added

Cc Me!

comment:2 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: sean@… added; eld.khattatov@… removed
Keywords: Dolfin removed
Port: dolfin added
Resolution: duplicate
Status: newclosed
Summary: Cannot port install dolfindolfin: Could NOT find Eigen3 (missing: EIGEN3_INCLUDE_DIR EIGEN3_VERSION_OK)

Duplicate of #43496.

comment:3 in reply to:  2 Changed 7 years ago by seanfarley (Sean Farley)

Resolution: duplicate
Status: closedreopened

Replying to ryandesign@…:

Duplicate of #43496.

This is not a duplicate of #43496. That ticket is a problem with swig whereas this ticket is a problem with a missing dependency on eigen3.

comment:4 Changed 7 years ago by seanfarley (Sean Farley)

Owner: changed from macports-tickets@… to sean@…
Status: reopenednew

comment:5 Changed 7 years ago by seanfarley (Sean Farley)

Resolution: fixed
Status: newclosed

Fixed in r120753.

Note: See TracTickets for help on using tickets.