Opened 15 years ago

Closed 15 years ago

#4386 closed defect (worksforme)

BUG: ghc fails to build

Reported by: k_karanikolas@… Owned by: gwright@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc:
Port:

Description

Building ghc under 10.4.2 with Xcode 2.1 stops while compiling what presumably looks like haskell wrappers to X11/Xlib

gcc -v reports:

Using built-in specs. Target: powerpc-apple-darwin8 Configured with: /private/var/tmp/gcc/gcc-5026.obj~19/src/configure --disable-checking --prefix=/ usr --mandir=/share/man --enable-languages=c,objc,c++,obj-c++ --program-transform-name=/ [cg][+.-]*$/s/$/-4.0/ --with-gxx-include-dir=/include/gcc/darwin/4.0/c++ --build=powerpc- apple-darwin8 --host=powerpc-apple-darwin8 --target=powerpc-apple-darwin8 Thread model: posix gcc version 4.0.0 (Apple Computer, Inc. build 5026)

Attachments (1)

ghc-build.txt (136.1 KB) - added by k_karanikolas@… 15 years ago.
Build Log

Download all attachments as: .zip

Change History (15)

Changed 15 years ago by k_karanikolas@…

Attachment: ghc-build.txt added

Build Log

comment:1 Changed 15 years ago by gwright@…

Status: newassigned

I'll take a look at this, but it looks at first as if it's an upstream problem.

ghc-6.4.1 will be released in a few days; I've already tested snapshots. That might fix the issue.

-Greg

comment:2 Changed 15 years ago by gwright@…

Hi Kostas,

ghc-6.4 builds using gcc-3.3, not 4.0 (ghc-6.4.1 will use 4.0). What is gcc-3.3 -v on your system? Build 1809 is what I've used.

Also, what is /opt/local/bin/perl -v? (ghc uses a perl script to do assembly code postprocessing)

-Greg

comment:3 Changed 15 years ago by k_karanikolas@…

Hi Greg,

gcc-3.3 -v reports: Reading specs from /usr/libexec/gcc/darwin/ppc/3.3/specs Thread model: posix gcc version 3.3 20030304 (Apple Computer, Inc. build 1809)

/opt/local/bin/perl -v also reports: This is perl, v5.8.7 built for darwin-2level

When I tried building ghc last week it only got as far as building the bootstrap compiler, but after I synced this morning it got as far as the X11 support.

It would be nice if it was possible to have the portfile warn, or even prevent people from trying to build packages with known incompatible versions of the compiler toolset.

Kostas

comment:4 Changed 15 years ago by gwright@…

Hi Kostas,

It's not an Xcode tool chain issue -- you're using the same gcc and perl as I am. I think it is a bug in ghc itself (independent of darwinports).

What's your hardware and the output of "uname -a"?

THanks. Greg

comment:5 Changed 15 years ago by gwright@…

Hi Kostas,

I just wanted to clear up one possible misunderstanding: the portfile does in fact build ghc using gcc-3.3 automatically. gcc-3.3 is installed by default under Xcode 2.1, in addition to the usual gcc-4.0. You don't have to do anything; the portfile takes care of it for you. (No need to mess with gcc_select.)

The error you are experiencing is likely a ghc bug related to code generation on your specific hardware. That's why I asked exactly what you are running on.

Best Wishes, Greg

comment:6 Changed 15 years ago by k_karanikolas@…

Hi Greg,

I'm using a 1.6 PowerBoook G4 with 1 Gig of RAM

uname -a reports: Darwin PowerBook.local 8.2.0 Darwin Kernel Version 8.2.0: Fri Jun 24 17:46:54 PDT 2005; root:xnu-792.2.4.obj~3/RELEASE_PPC Power Macintosh powerpc

Thanks, Kostas

comment:7 Changed 15 years ago by gwright@…

Owner: changed from darwinports-bugs@… to gwright@…
Status: assignednew

comment:8 Changed 15 years ago by gwright@…

6.4.1 is now scheduled to be released on Monday. I expect to have the portfile updated by Tuesday, since the snapshots have been building without trouble.

It would be helpful if people experiencing this bug (which I have not been able to reproduce) would test the new portfile as soon as it becomes available.

Thanks, Greg

comment:9 Changed 15 years ago by gwright@…

The 6.4.1 portfile has just been committed. Please give it a try.

Greg

comment:10 Changed 15 years ago by k_karanikolas@…

Hi Greg,

Unfortunatelly the build still stops, at exactly the same point. Assuming the problem manifests only on my machine what could possibly affect the build ? It would be nice if we could get more people to test this port though.

Regards, Kostas

comment:11 Changed 15 years ago by gwright@…

Status: newassigned

Hi Kostas,

This is strange. Are you running the standard Apple X11 installation? One thing to check is that your X11 runtime and X11 SDK are the same version. Did you install both at the same time?

No one on the ghc list has reported a problem with the X11 bindings (for the release or the snapshots) so I'm beginning to wonder if your X11 install went wrong. One possible problem is that if you installed Xcode and then went back and installed X11 without first uninstalling Xcode. Apple documentation warn that you can't add options to an Xcode install without first uninstalling anf then doing a complete reinstall, including the optional parts.

Another thing to check is that some portfile didn't stomp on your X11 by installing darwinports X11 over your Apple X11. If that happened, you will have to reinstall X11.

Best Wishes, Greg

comment:12 Changed 15 years ago by gwright@…

Is this still a problem? If not, I will close the bug.

Best Wishes, Greg

comment:13 Changed 15 years ago by mww@…

Summary: ghc fails to buildBUG: ghc fails to build

comment:14 Changed 15 years ago by gwright@…

Resolution: worksforme
Status: assignedclosed

Having no report that this is still a problem, I am closing this bug.

-Greg

Note: See TracTickets for help on using tickets.