Opened 6 years ago

Closed 6 years ago

#43938 closed defect (fixed)

gettext @0.18.3.2 update to 0.19.1 - avoid 0.19

Reported by: mkae (Marko Käning) Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version:
Keywords: haspatch Cc: deric@…, frozencemetery (Robbie Harwood), feliks.kluzniak@…, bwalle (Bernhard Walle), icemac (Michael Howitz), fleason (Fred Leason), anddam (Andrea D'Amore), bK4gYuRo, rcobbe, cooljeanius (Eric Gallager)
Port: gettext

Description (last modified by seanfarley (Sean Farley))

According to the gettext mailing list there are bugs in its packaging causing error like so:

...
creating mercurial/locale/el
creating mercurial/locale/el/LC_MESSAGES
generating mercurial/locale/el/LC_MESSAGES/hg.mo from i18n/el.po
msgfmt -v -o mercurial/locale/el/LC_MESSAGES/hg.mo i18n/el.po -c
i18n/el.po:7: warning: header field 'Language' missing in header
msgfmt: found 1 fatal error
312 translated messages, 35 fuzzy translations, 1936 untranslated messages.
error: command 'msgfmt' failed with exit status 1
make: *** [build] Error 1
make: *** Waiting for unfinished jobs....
mv hg.1.gendoc.txt.tmp hg.1.gendoc.txt
/opt/local/Library/Frameworks/Python.framework/Versions/2.7/bin/python2.7 runrst hgmanpage  --halt warning \
	  --strip-elements-with-class htmlonly hg.1.txt hg.1
/opt/local/Library/Frameworks/Python.framework/Versions/2.7/bin/python2.7 runrst html  --halt warning \
	  --link-stylesheet --stylesheet-path style.css hg.1.txt hg.1.html
make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_mercurial/mercurial/work/3.0.1/doc'
make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_mercurial/mercurial/work/3.0.1'
Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_mercurial/mercurial/work/3.0.1" && make -j8 -w all PYTHON=/opt/local/Library/Frameworks/Python.framework/Versions/2.7/bin/python2.7 
Exit code: 2
Error: org.macports.build for port mercurial returned: command execution failed
DEBUG: Error code: CHILDSTATUS 1091 2
DEBUG: Backtrace: command execution failed
Warning: targets not executed for mercurial: org.macports.install org.macports.build org.macports.destroot

Attachments (1)

patch-Portfile.diff (1.0 KB) - added by mkae (Marko Käning) 6 years ago.
Couldn't commit to the SVN server right now, but this fixes this issue

Download all attachments as: .zip

Change History (24)

comment:1 Changed 6 years ago by frozencemetery (Robbie Harwood)

I have this problem as well on OSX 10.6.8 with a similar msgfmt problem in main.log.

comment:2 Changed 6 years ago by frozencemetery (Robbie Harwood)

Cc: rharwood@… added

Cc Me!

comment:3 Changed 6 years ago by feliks.kluzniak@…

Cc: feliks.kluzniak@… added

Cc Me!

comment:4 Changed 6 years ago by jdgoettsch (Jeffrey Goettsch)

I had the same problem on 10.6.8. I tried again a few times and finally it worked.

I have this problem on the latest 10.5 as well, except the sixth line from the bottom in the snippet above is different:

Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_mercurial/mercurial/work/3.0.1" && make -j3 -w all PYTHON=/opt/local/Library/Frameworks/Python.framework/Versions/2.7/bin/python2.7

comment:5 Changed 6 years ago by bwalle (Bernhard Walle)

Cc: bernhard@… added

Cc Me!

comment:6 in reply to:  4 Changed 6 years ago by frozencemetery (Robbie Harwood)

Replying to jeff@…:

I had the same problem on 10.6.8. I tried again a few times and finally it worked.

Same here. Race condition in the build system?

comment:7 Changed 6 years ago by mopihopi

I had the same issue. It seems to be caused by the update to gettext 0.19 which occurred earlier today. Activing the previous version of gettext resolved the issue for me. e.g. sudo port activate gettext @0.18.3.2_0

According to https://lists.gnu.org/archive/html/bug-gettext/2014-06/msg00007.html it sounds like this may be a bug introduced in gettext 0.19 that will be corrected in a soon-to-be-released gettext 0.19.1.

comment:8 Changed 6 years ago by icemac (Michael Howitz)

Cc: mh@… added

Cc Me!

comment:9 in reply to:  7 Changed 6 years ago by icemac (Michael Howitz)

Replying to mopihopi@…:

I had the same issue. It seems to be caused by the update to gettext 0.19 which occurred earlier today. Activing the previous version of gettext resolved the issue for me. e.g. sudo port activate gettext @0.18.3.2_0

After downgrading gettext, I also was able to install mercurial 3.0.1.

comment:10 Changed 6 years ago by seanfarley (Sean Farley)

Description: modified (diff)
Owner: changed from sean@… to ryandesign@…
Summary: mercurial 3.0.1 update failsgettext 0.19 needs to be updated to 0.19.1 when released

Ok, so this isn't a mercurial issue at all but a gettext one.

comment:11 in reply to:  7 ; Changed 6 years ago by ryandesign (Ryan Schmidt)

Replying to mopihopi@…:

According to https://lists.gnu.org/archive/html/bug-gettext/2014-06/msg00007.html it sounds like this may be a bug introduced in gettext 0.19 that will be corrected in a soon-to-be-released gettext 0.19.1.

According to that link, the fix won't be until "this week" so unless a better idea is suggested in the next couple hours I may revert the port to the previous 0.18.3.2 version until then.

comment:12 Changed 6 years ago by fleason (Fred Leason)

Cc: fleason@… added

Cc Me!

comment:13 Changed 6 years ago by anddam (Andrea D'Amore)

Cc: and.damore@… added

Cc Me!

comment:14 in reply to:  11 Changed 6 years ago by ryandesign (Ryan Schmidt)

Replying to ryandesign@…:

I may revert the port to the previous 0.18.3.2 version until then.

r120812

comment:15 Changed 6 years ago by bK4gYuRo

Just wanted to report that downgrading gettext to @0.18.3.2_0+universal allowed me to build mercurial 3.0.1_0 on 10.7.5

comment:16 Changed 6 years ago by bK4gYuRo

Cc: macports@… added

Cc Me!

comment:17 Changed 6 years ago by anddam (Andrea D'Amore)

Port: gettext added; mercurial removed
Summary: gettext 0.19 needs to be updated to 0.19.1 when releasedgettext @0.18.3.2 update to 0.19.1 - avoid 0.19

Edit summary and port field, the issue is with gettext, not mercurial.

comment:18 Changed 6 years ago by fleason (Fred Leason)

port upgrade gettext

now reverts to 18.3

comment:19 Changed 6 years ago by rcobbe

Cc: cobbe@… added

Cc Me!

comment:20 Changed 6 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:21 Changed 6 years ago by mopihopi

Changed 6 years ago by mkae (Marko Käning)

Attachment: patch-Portfile.diff added

Couldn't commit to the SVN server right now, but this fixes this issue

comment:22 Changed 6 years ago by mkae (Marko Käning)

Keywords: haspatch added

comment:23 Changed 6 years ago by mkae (Marko Käning)

Resolution: fixed
Status: newclosed

Committed eventually as r120880

Note: See TracTickets for help on using tickets.