Opened 7 years ago

Closed 7 years ago

#43948 closed defect (duplicate)

qt4-mac @4.8.6_0: kCFURLIsHiddenKey and CFURLCopyResourcePropertyForKey not declared in this scope

Reported by: trg818 (Thomas Ruedas) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.0
Keywords: Cc: michaelld (Michael Dickens)
Port: qt4-mac

Description

During an update of outdated ports, qt4-mac-4.8.6_0 was downloaded, and an installation was attempted. The compilation ran into several errors, the last of which (before premature termination) reads as follows:

:info:build dialogs/qfiledialog_mac.mm:300: error: ‘kCFURLIsHiddenKey’ was not declared in this scope
:info:build dialogs/qfiledialog_mac.mm:300: error: ‘CFURLCopyResourcePropertyFor
Key’ was not declared in this scope
:info:build make[1]: *** [.obj/release-shared/qfiledialog_mac.o] Error 1
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_qt4-mac/qt4-mac/work/qt-everywhere-opensource-src-4.8.6/src/gui'
:info:build make: *** [sub-gui-all-ordered] Error 2
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_qt4-mac/qt4-mac/work/qt-everywhere-opensource-src-4.8.6'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_qt4-mac/qt4-mac/work/qt-everywhere-opensource-src-4.8.6" && /usr/bin/make -wall 
:info:build Exit code: 2
:error:build org.macports.build for port qt4-mac returned: command execution failed
:debug:build Error code: CHILDSTATUS 71247 2
:debug:build Backtrace: command execution failed
    while executing
"system -nice 0 $fullcmdstring"
    ("eval" body line 1)
    invoked from within
"eval system $notty $nice \$fullcmdstring"
    invoked from within
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"portbuild::build_main org.macports.build"
    ("eval" body line 1)
    invoked from within
"eval $procedure $targetname"
:info:build Warning: targets not executed for qt4-mac: org.macports.install org.
macports.build org.macports.destroot

The full logfile from the compilation is attached to this ticket. The system is running under Mac OS 10.5.8.

Thomas

Attachments (1)

main.log (1.1 MB) - added by trg818 (Thomas Ruedas) 7 years ago.
complete logfile of installation attempt

Download all attachments as: .zip

Change History (2)

Changed 7 years ago by trg818 (Thomas Ruedas)

Attachment: main.log added

complete logfile of installation attempt

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: michaelld@… added
Port: qt4-mac added; qt4-mac-4.8.6_0 removed
Resolution: duplicate
Status: newclosed
Summary: qt4-mac-4.8.6_0 broken, compilation fails with errorsqt4-mac @4.8.6_0: kCFURLIsHiddenKey and CFURLCopyResourcePropertyForKey not declared in this scope

Duplicate of #43746.

Note: See TracTickets for help on using tickets.