Opened 7 years ago

Closed 7 years ago

#43961 closed defect (invalid)

quodlibet @3.1.1 missing py27-gst-python dependency

Reported by: dave.parillo@… Owned by: elelay (Eric Le Lay)
Priority: Normal Milestone:
Component: ports Version: 2.3.0
Keywords: Cc: rmstonecipher@…
Port: quodlibet

Description

After installing QL 3.1.1, QL runs and imports a music library, but no files of any type (mp3, ogg) play.

Error displayed in QL:

No GStreamer element found to handle the following media format: 'gstreamer|1.0|quodlibet|MPEG-4 AAC

Manually installed py27-gst-python and that fixed the problem.

Didn't see an entry for gst-python bindings in the most recent port file or in r119946.

Change History (5)

comment:1 Changed 7 years ago by mf2k (Frank Schima)

Cc: elelay@… removed
Owner: changed from macports-tickets@… to elelay@…

comment:2 Changed 7 years ago by elelay (Eric Le Lay)

Thanks for reporting!

py27-gst-python should not be necessary since QL 3.x uses the GObject bindings, not the direct python bindings as in QL 2.x.

Your problem looks more like missing gstreamer1-gst-plugins-ugly. The fact that installing py27-gst-python fixed the problem is weird. I'll investigate more.

Can you try to uninstall py27-gst-python and see if QL still works?

comment:3 in reply to:  2 Changed 7 years ago by dave.parillo@…

Strange results:

~$ sudo port uninstall py27-gst-python
Password:
--->  Unable to uninstall py27-gst-python @0.10.22_2, the following ports depend on it:
--->  	quodlibet @2.6.2_0
Error: org.macports.uninstall for port py27-gst-python returned: Please uninstall the ports that depend on py27-gst-python first.
Please see the log file for port py27-gst-python for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_registry_portfiles_py27-gst-python-0.10.22_2_66c9ff2dacfa6448c46aa8c25e624420bf59c4b41269943553dc716ab75ab8fa-1895/py27-gst-python/main.log
Warning: Failed to execute portfile from registry for py27-gst-python @0.10.22_2
--->  Unable to uninstall py27-gst-python @0.10.22_2, the following ports depend on it:
--->  	quodlibet @2.6.2_0
Error: port uninstall failed: Please uninstall the ports that depend on py27-gst-python first.
~$ sudo port list installed | grep quodlibet
quodlibet                      @3.1.1          python/quodlibet
quodlibet                      @3.1.1          python/quodlibet

Ran port uninstall quodlibet @2.6.2_0 and port uninstall py27-gst-python and quodlibet still runs and still plays mpg and m4a.

Sorry for the false alarm. I am a bit perplexed why sudo port list installed | grep quodlibet doesn't return all the ports installed. Clearly my ignorance of how the port command works. Feel free to close, I can't do that.

Replying to elelay@…:

Can you try to uninstall py27-gst-python and see if QL still works?

comment:4 Changed 7 years ago by elelay (Eric Le Lay)

Hi, no worries: I'd rather get a false alarm than port broken for ages :-)

I use port installed quodlibet to show what versions are installed.

port list installed lists available versions of installed packages whereas port installed quodlibet lists actual installed versions of quodlibet. It's much faster and also has a more verbose output.

http://guide.macports.org/#using.port.list

comment:5 Changed 7 years ago by elelay (Eric Le Lay)

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.