Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#43965 closed defect (fixed)

tclsh8.5 takes 100% CPU drawing fetch progress bar

Reported by: ryandesign (Ryan Schmidt) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: base Version: 2.3.99
Keywords: Cc: harciga
Port:

Description

While fetching a large distfile, tclsh8.5 takes 100% CPU, presumably to draw the new progress bar.

Change History (6)

comment:1 Changed 7 years ago by neverpanic (Clemens Lang)

I noticed the same thing, but I'm not entirely convinced it's the progress bar. Do you see the same thing in 2.3.0?

This could just as well be caused by the new code using curl_multi_perform to be able to quickly handle Ctrl+C.

comment:2 Changed 7 years ago by harciga

I've experienced two times now —since macports upgrade— issues with the progress bar bugging out with it filling over the entire screen while flashing progress status text at different offsets, leaving me after I ctrl-brk with an inverted terminal text.

I have no idea how to report this, perhaps I can log all terminal output for when it happens again.

Last edited 7 years ago by harciga (previous) (diff)

comment:3 Changed 7 years ago by harciga

Cc: starkhalo@… added

Cc Me!

comment:4 in reply to:  2 Changed 7 years ago by neverpanic (Clemens Lang)

Replying to starkhalo@…:

I've experienced two times now —since macports upgrade— issues with the progress bar bugging out with it filling over the entire screen while flashing progress status text at different offsets, leaving me after I ctrl-brk with an inverted terminal text.

That's a different issue, please open a separate ticket about this. I don't think there's anything we can do about that as long as we don't have signal handling (which is what I'm currently working on on trunk), though. You'll probably also get weird results when resizing the terminal or in very small terminals. We need to handle SIGWINCH to fix this.

comment:5 Changed 7 years ago by neverpanic (Clemens Lang)

Resolution: fixed
Status: newclosed

Fixed in r120901, r120902.

Not setting a milestone, because this was caused by the signal handling code, not the progress bar, and that hasn't been in a released version, so it's a trunk-only bug.

comment:6 Changed 7 years ago by ryandesign (Ryan Schmidt)

Thanks. I forgot to let you know that yes, I did try 2.3.0, and did not see the same problem there.

Note: See TracTickets for help on using tickets.