Opened 6 years ago

Closed 6 years ago

#44116 closed enhancement (duplicate)

php-apache24handler subport

Reported by: Schamschula (Marius Schamschula) Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.3.0
Keywords: haspatch Cc:
Port: php

Description

I've added a subport to enable mod_php5x for apache24-devel. The new subport was required as apache2hander needs different paths to be set.

I also added more instructions to the notes: by default mod_php55.so is not executable, and httpd.conf will not load the module as the path has not been fully specified. Further a mime type has to be added for any php script to execute.

Attachments (2)

Portfile-php55.diff (3.3 KB) - added by Schamschula (Marius Schamschula) 6 years ago.
patch-apache24-devel.diff (964 bytes) - added by Schamschula (Marius Schamschula) 6 years ago.

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by Schamschula (Marius Schamschula)

Attachment: Portfile-php55.diff added

comment:1 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… removed
Keywords: haspatch added
Owner: changed from macports-tickets@… to ryandesign@…
Port: php added; php55 removed
Summary: php55-apache24handler subportphp-apache24handler subport

I don't really intend to add a new ${php}-apache24handler subport; rather, I intend for the work that has been done on the apache24-devel port be moved back into the apache2 port eventually, at which point the ${php}-apache2handler port (and all other ports that use apache2) will need to be updated for the new paths.

Why would it matter that mod_${php}.so doesn't have the executable bit? It isn't an executable; it's a dynamic library; it shouldn't have the executable bit.

The way you've written the new documentation is not the way I envisioned users solving that problem. Instead, they should edit their httpd.conf and include the file mod_${php}.conf that the ${php}-apache2handler port installs. This information should be added to the notes; it has been requested many times before. If the mod_${php}.conf file doesn't contain all the necessary directives, they should be added.

comment:2 in reply to:  1 Changed 6 years ago by Schamschula (Marius Schamschula)

Replying to ryandesign@…:

I don't really intend to add a new ${php}-apache24handler subport; rather, I intend for the work that has been done on the apache24-devel port be moved back into the apache2 port eventually, at which point the ${php}-apache2handler port (and all other ports that use apache2) will need to be updated for the new paths.

So do you propose to move apache24-devel so it violates the mtree as does apache2? If not, apache2 needs to be installed into the same paths as apache24-devel.

Otherwise, the current ${php}-apache2handler can only be installed for apache2, and I'll have to keep building from my local Portfile, and wish others running apache24-develgood luck, as I don't want to break the subport for ${php}-apache2handler.

I don't want to have ${php}-apache2handler install apache2 when I try to update ${php} (as has happened once), since I inadvertently overwrote my locally modified Portfile. This creates quite a little mess.

Why would it matter that mod_${php}.so doesn't have the executable bit? It isn't an executable; it's a dynamic library; it shouldn't have the executable bit.

I double checked, and sure enough it works without the chmod. However, do a ls -l on the apache2/modules directory. You'll find mod_${php}.so is the only one that does not have executable bits set. Maybe the apache24-devel installer is doing something wrong…

The way you've written the new documentation is not the way I envisioned users solving that problem. Instead, they should edit their httpd.conf and include the file mod_${php}.conf that the ${php}-apache2handler port installs. This information should be added to the notes; it has been requested many times before. If the mod_${php}.conf file doesn't contain all the necessary directives, they should be added.

I am aware that the documentation is not ideal. It was the best I could do after spending the better part of the day trying to find a way to get ${php}-apache2(4)handler installed on my machine. I just wanted to make others aware of the issues I ran into.

comment:3 Changed 6 years ago by Schamschula (Marius Schamschula)

In the meantime, until such time as apache2 and apache24-devel are merged, I've attached a patch that allows the use of the apache2handler to install against apache24-devel.

Changed 6 years ago by Schamschula (Marius Schamschula)

Attachment: patch-apache24-devel.diff added

comment:4 Changed 6 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #41478.

Note: See TracTickets for help on using tickets.