Opened 6 years ago

Closed 6 years ago

#44303 closed update (fixed)

hypre @2.9.0b: Upgrade to 2.9.1a to fix compile error

Reported by: samuel.bateman@… Owned by: seanfarley (Sean Farley)
Priority: Normal Milestone:
Component: ports Version: 2.3.1
Keywords: Cc:
Port: hypre

Description

HYPRE 2.9.0b doesn't compile correctly when using an external BLAS library, which is the default. This is because of an issue in the Makefile. Neither 2.8.0b nor 2.9.1a have the problem.

I've attached a Portfile that works for me with 2.9.1a.

Attachments (1)

Portfile (1.3 KB) - added by samuel.bateman@… 6 years ago.

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by samuel.bateman@…

Attachment: Portfile added

comment:1 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: sean@… removed
Owner: changed from macports-tickets@… to sean@…

Please attach a unified diff of your proposed changes.

comment:2 Changed 6 years ago by seanfarley (Sean Farley)

Thanks, I'll look at it tomorrow.

comment:3 Changed 6 years ago by seanfarley (Sean Farley)

Resolution: fixed
Status: newclosed

Updated in r121959. Thanks for the patch!

Note: See TracTickets for help on using tickets.