Opened 6 years ago

Last modified 9 months ago

#44402 new defect

jpilot has missing dependencies

Reported by: mf2k (Frank Schima) Owned by: kristian.peters@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: jpilot

Description

jpilot needs to add a library dependency on libgcrypt among a bunch of other ports:

$ otool -L /opt/local/lib/jpilot/plugins/libkeyring.so
/opt/local/lib/jpilot/plugins/libkeyring.so:
	/opt/local/lib/libgtk-x11-2.0.0.dylib (compatibility version 2401.0.0, current version 2401.24.0)
	/opt/local/lib/libgdk-x11-2.0.0.dylib (compatibility version 2401.0.0, current version 2401.24.0)
	/opt/local/lib/libpangocairo-1.0.0.dylib (compatibility version 3601.0.0, current version 3601.5.0)
	/opt/local/lib/libXrender.1.dylib (compatibility version 5.0.0, current version 5.0.0)
	/opt/local/lib/libXinerama.1.dylib (compatibility version 2.0.0, current version 2.0.0)
	/opt/local/lib/libXi.6.dylib (compatibility version 8.0.0, current version 8.0.0)
	/opt/local/lib/libXrandr.2.dylib (compatibility version 5.0.0, current version 5.0.0)
	/opt/local/lib/libXcursor.1.dylib (compatibility version 2.0.0, current version 2.2.0)
	/opt/local/lib/libXcomposite.1.dylib (compatibility version 2.0.0, current version 2.0.0)
	/opt/local/lib/libXdamage.1.dylib (compatibility version 3.0.0, current version 3.0.0)
	/opt/local/lib/libXfixes.3.dylib (compatibility version 5.0.0, current version 5.0.0)
	/opt/local/lib/libX11.6.dylib (compatibility version 10.0.0, current version 10.0.0)
	/opt/local/lib/libXext.6.dylib (compatibility version 11.0.0, current version 11.0.0)
	/opt/local/lib/libatk-1.0.0.dylib (compatibility version 21210.0.0, current version 21210.1.0)
	/opt/local/lib/libcairo.2.dylib (compatibility version 11203.0.0, current version 11203.16.0)
	/opt/local/lib/libgdk_pixbuf-2.0.0.dylib (compatibility version 3001.0.0, current version 3001.8.0)
	/opt/local/lib/libgio-2.0.0.dylib (compatibility version 4001.0.0, current version 4001.0.0)
	/opt/local/lib/libpangoft2-1.0.0.dylib (compatibility version 3601.0.0, current version 3601.5.0)
	/opt/local/lib/libpango-1.0.0.dylib (compatibility version 3601.0.0, current version 3601.5.0)
	/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 1197.1.1)
	/opt/local/lib/libgobject-2.0.0.dylib (compatibility version 4001.0.0, current version 4001.0.0)
	/opt/local/lib/libglib-2.0.0.dylib (compatibility version 4001.0.0, current version 4001.0.0)
	/opt/local/lib/libintl.8.dylib (compatibility version 10.0.0, current version 10.2.0)
	/opt/local/lib/libfontconfig.1.dylib (compatibility version 10.0.0, current version 10.0.0)
	/opt/local/lib/libfreetype.6.dylib (compatibility version 18.0.0, current version 18.2.0)
	/opt/local/lib/libgcrypt.20.dylib (compatibility version 21.0.0, current version 21.1.0)
	/opt/local/lib/libgpg-error.0.dylib (compatibility version 12.0.0, current version 12.0.0)
$ port info --depends jpilot
depends_build: port:intltool, port:pkgconfig
depends_run: 
depends_fetch: 
depends_lib: port:libiconv, port:gtk2, port:pilot-link
depends_extract: 

Change History (1)

comment:1 Changed 9 months ago by ewenmcneill (Ewen McNeill)

See also #60350, where libkeyring.so is no longer built automatically (due to needing libgcrypt installed, and additional linking flags).

Ewen

Note: See TracTickets for help on using tickets.