Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#44539 closed defect (duplicate)

vxl @1.17.0: error: cannot cast from type 'std::ofstream' (aka 'basic_ofstream<char>') to pointer type 'void *'

Reported by: gjolleyrogers (Garry Jolley-Rogers) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: mavericks Cc:
Port: vxl

Description (last modified by dbevans (David B. Evans))

Repeated errors. Sorry I'm a noob at this but I have spent the night banging at it repeatedly to no avail.. log file extract as follows....

:info:build [ 25%] Built target vnl
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_vxl/vxl/work/vxl-1.17.0'
:info:build make: *** [all] Error 2
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_vxl/vxl/work/vxl-1.17.0'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_vxl/vxl/work/vxl-1.17.0" && /usr/bin/make -j8 -w all 
:info:build Exit code: 2
:error:build org.macports.build for port vxl returned: command execution failed
:debug:build Error code: CHILDSTATUS 41200 2
:debug:build Backtrace: command execution failed
    while executing
"system -nice 0 $fullcmdstring"
    ("eval" body line 1)
    invoked from within
"eval system $notty $nice \$fullcmdstring"
    invoked from within
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"portbuild::build_main org.macports.build"
    ("eval" body line 1)
    invoked from within
"eval $procedure $targetname"

Attachments (1)

vxl.buildlog.txt (1.5 MB) - added by gjolleyrogers (Garry Jolley-Rogers) 6 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 6 years ago by dbevans (David B. Evans)

Description: modified (diff)
Version: 2.3.1

Please use WikiFormatting for readability when quoting log files and attach a copy of the full build log. Thanks.

Changed 6 years ago by gjolleyrogers (Garry Jolley-Rogers)

Attachment: vxl.buildlog.txt added

comment:2 Changed 6 years ago by ryandesign (Ryan Schmidt)

Keywords: mavericks added
Port: vlx added; VXL removed
Resolution: duplicate
Status: newclosed
Summary: VXL installation on OSX 10.9.4vlx @1.17.0: error: cannot cast from type 'std::ofstream' (aka 'basic_ofstream<char>') to pointer type 'void *'
:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_vxl/vxl/work/vxl-1.17.0/core/vul/vul_psfile.h:40:28: error: cannot cast from type 'std::ofstream' (aka 'basic_ofstream<char>') to pointer type 'void *'
:info:build   operator bool() { return (void*)output_filestream!=(void*)0; }
:info:build                            ^~~~~~~~~~~~~~~~~~~~~~~~

Duplicate of #41241.

comment:3 Changed 6 years ago by ryandesign (Ryan Schmidt)

Port: vxl added; vlx removed
Summary: vlx @1.17.0: error: cannot cast from type 'std::ofstream' (aka 'basic_ofstream<char>') to pointer type 'void *'vxl @1.17.0: error: cannot cast from type 'std::ofstream' (aka 'basic_ofstream<char>') to pointer type 'void *'
Note: See TracTickets for help on using tickets.