Opened 7 years ago

Closed 7 years ago

#44642 closed defect (fixed)

dia: undefined symbols _g_module_close _g_module_error _g_module_open _g_module_symbol

Reported by: felipekfcosta@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.1
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: dia

Description (last modified by ryandesign (Ryan Schmidt))

I'm trying to install Dia using MacPorts on an iMac G4 with OS 10.4 Tiger, and I was able to build all dependencies, but when I finally got to the package 'dia' it gives me the following message:

Error: org.macports.build for port dia returned: command execution failed

An excerpt of the log, with the error:

:info:build /bin/sh ../libtool  --tag=CC   --mode=link /opt/local/bin/gcc-apple-4.2  -I/opt/local/include/libxml2 -I/opt/local/include/freetype2 -pipe -Os -arch ppc  -Wall --std=c89 -Wdeclaration-after-statement -Wmissing-prototypes -Wmissing-declarations -finline-functions -fstrict-aliasing -Wpointer-arith -Winit-self -Wformat-nonliteral -export-dynamic -L/opt/local/lib -Wl,-headerpad_max_install_names -arch ppc -o dia confirm.o exit_dialog.o diagram.o preferences.o load_save.o properties-dialog.o defaults.o undo.o object_ops.o layer_dialog.o commands.o app_procs.o connectionpoint_ops.o disp_callbacks.o display.o select.o color_area.o linewidth_area.o grid.o handle_ops.o interface.o modify_tool.o scroll_tool.o create_object.o magnify.o menus.o cut_n_paste.o render_gdk.o tool.o diapagelayout.o pagesetup.o filedlg.o find-and-replace.o plugin-manager.o dia-props.o gtkwrapbox.o gtkhwrapbox.o gtkvwrapbox.o cursor.o splash.o recent_files.o diagram_tree.o diagram_tree_window.o diagram_tree_menu.o diagram_tree_menu_callbacks.o sheets.o sheets_dialog.o sheets_dialog_callbacks.o autosave.o dynamic_refresh.o navigation.o diacanvas.o highlight.o textedit.o textedit_tool.o main.o ../lib/libdia.la   -lz -L/opt/local/lib -lfreetype -lz -lbz2 -L/opt/local/lib -lpng16 -Wl,-framework,CoreServices -Wl,-framework,ApplicationServices -L/opt/local/lib -lgtk-x11-2.0 -lgdk-x11-2.0 -lpangocairo-1.0 -lgio-2.0 -lXrender -lXinerama -lXi -lXrandr -lXcursor -lXcomposite -lXdamage -lXfixes -lX11 -lXext -latk-1.0 -lcairo -lgio-2.0 -lxml2 -lgdk_pixbuf-2.0 -lgthread-2.0 -lpangoft2-1.0 -lpango-1.0 -lm -lgobject-2.0 -lglib-2.0 -lintl -lfontconfig -lfreetype -lart_lgpl_2  -lpng -lz -lm -lintl   -L/opt/local/lib -lxml2 -lz -lpthread -liconv -lm -L/opt/local/lib -lart_lgpl_2   -lpng -lz -lm -lz
:info:build libtool: link: /opt/local/bin/gcc-apple-4.2 -I/opt/local/include/libxml2 -I/opt/local/include/freetype2 -pipe -Os -arch ppc -Wall --std=c89 -Wdeclaration-after-statement -Wmissing-prototypes -Wmissing-declarations -finline-functions -fstrict-aliasing -Wpointer-arith -Winit-self -Wformat-nonliteral -Wl,-headerpad_max_install_names -arch ppc -o .libs/dia confirm.o exit_dialog.o diagram.o preferences.o load_save.o properties-dialog.o defaults.o undo.o object_ops.o layer_dialog.o commands.o app_procs.o connectionpoint_ops.o disp_callbacks.o display.o select.o color_area.o linewidth_area.o grid.o handle_ops.o interface.o modify_tool.o scroll_tool.o create_object.o magnify.o menus.o cut_n_paste.o render_gdk.o tool.o diapagelayout.o pagesetup.o filedlg.o find-and-replace.o plugin-manager.o dia-props.o gtkwrapbox.o gtkhwrapbox.o gtkvwrapbox.o cursor.o splash.o recent_files.o diagram_tree.o diagram_tree_window.o diagram_tree_menu.o diagram_tree_menu_callbacks.o sheets.o sheets_dialog.o sheets_dialog_callbacks.o autosave.o dynamic_refresh.o navigation.o diacanvas.o highlight.o textedit.o textedit_tool.o main.o -Wl,-framework -Wl,CoreServices -Wl,-framework -Wl,ApplicationServices  -L/opt/local/lib ../lib/.libs/libdia.dylib -lbz2 /opt/local/lib/libgtk-x11-2.0.dylib /opt/local/lib/libgdk-x11-2.0.dylib /opt/local/lib/libpangocairo-1.0.dylib /opt/local/lib/libXrender.dylib /opt/local/lib/libXinerama.dylib /opt/local/lib/libXi.dylib /opt/local/lib/libXrandr.dylib /opt/local/lib/libXcursor.dylib /opt/local/lib/libXcomposite.dylib /opt/local/lib/libXdamage.dylib /opt/local/lib/libXfixes.dylib /opt/local/lib/libX11.dylib /opt/local/lib/libXext.dylib /opt/local/lib/libatk-1.0.dylib /opt/local/lib/libcairo.dylib /opt/local/lib/libgio-2.0.dylib /opt/local/lib/libgdk_pixbuf-2.0.dylib /opt/local/lib/libgthread-2.0.dylib /opt/local/lib/libpangoft2-1.0.dylib /opt/local/lib/libpango-1.0.dylib /opt/local/lib/libgobject-2.0.dylib /opt/local/lib/libglib-2.0.dylib /opt/local/lib/libfontconfig.dylib /opt/local/lib/libfreetype.dylib /opt/local/lib/libintl.dylib /opt/local/lib/libxml2.dylib -lpthread /opt/local/lib/libiconv.dylib /opt/local/lib/libart_lgpl_2.dylib /opt/local/lib/libpng16.dylib -lm -lz -pthread -framework Carbon -framework Cocoa
:info:build /usr/bin/ld: warning multiple definitions of symbol _object_copy
:info:build ../lib/.libs/libdia.dylib(single module) definition of _object_copy
:info:build /usr/lib/libobjc.A.dylib(libobjc.ppc.o) definition of _object_copy
:info:build /usr/bin/ld: Undefined symbols:
:info:build _g_module_close
:info:build _g_module_error
:info:build _g_module_open
:info:build _g_module_symbol
:info:build collect2: ld returned 1 exit status

I believe the solution goes along the lines of adding /opt/local/lib/libgmodule-2.0.dylib to the -L argument list, but unfortunately I don't know how to do so.

Attachments (1)

main.log (170.2 KB) - added by felipekfcosta@… 7 years ago.
Build log

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by felipekfcosta@…

Attachment: main.log added

Build log

comment:1 Changed 7 years ago by felipekfcosta@…

Cc: felipekfcosta@… added

Cc Me!

comment:2 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added; felipekfcosta@… removed
Keywords: Dia ld gmodule removed
Port: dia added; Dia removed
Summary: Error installing Diadia: undefined symbols _g_module_close _g_module_error _g_module_open _g_module_symbol

I see we fixed the same for another port in r96672. I'm first trying to reproduce the failure; then I'll try that fix.

comment:3 Changed 7 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)

I am able to reproduce the failure if the apple-gcc42 port is installed with the bootstrap variant and the cctools and ld64 ports are not installed.

I am not able to reproduce the failure if the apple-gcc42 port is installed without the bootstrap variant; deselecting this variant brings in cctools and ld64 as dependencies.

So the immediate workaround and one which I recommend to you is to reinstall the apple-gcc42 port without the bootstrap variant; this will probably have a positive overall effect on your ability to install even other ports.

However I will also look into fixing this port for the bootstrap case.

Last edited 7 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:4 in reply to:  3 Changed 7 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

Replying to ryandesign@…:

However I will also look into fixing this port for the bootstrap case.

Instead I've added a note to the apple-gcc42 port in r123882 advising users to reinstall without the bootstrap variant. That's really what we want Tiger users to do; we want users to use ld64, not the old linker that came with Xcode.

Note: See TracTickets for help on using tickets.