Opened 6 years ago

Closed 6 years ago

#44740 closed enhancement (fixed)

wine, wine-devel, wine-crossover: add Wine Mono

Reported by: jodi.a.schneider@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: jyrkiwahlstedt, cooljeanius (Eric Gallager), jeremyhu (Jeremy Huddleston Sequoia)
Port: wine, wine-devel, wine-crossover

Description

I suggest adding Mono as a dependency. Mono is expected for Wine: http://wiki.winehq.org/Mono

(monocfg tries to install Mono. But for me it failed & I got 2 crashes. Better if it's already installed.)

wine@1.6.2
Platform: darwin 13 i386
System: OS X 10.9.4 (13E28)

Change History (5)

comment:1 Changed 6 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:2 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… openmaintainer@… jodi.a.schneider@… removed
Keywords: dependencies removed
Owner: changed from macports-tickets@… to ryandesign@…
Port: wine-devel wine-crossover added
Summary: wine@1.6.2 add Mono as a dependencywine, wine-devel, wine-crossover: add Wine Mono
Type: defectenhancement
Version: 2.3.1

So it sounds like we're not talking about adding a dependency on the MacPorts mono port, but rather adding a Windows binary of Wine Mono to the wine ports, for software running in wine to use, much as we already add a binary of Wine Gecko.

Could you give me the exact set of steps to follow on my machine to reproduce the failure you experienced, so that I can verify whether I've succeeded in fixing it?

comment:3 Changed 6 years ago by jodi.a.schneider@…

Failure resulted from:

  • sudo port install wine
  • winecfg
  • click on the popup that appears (hard crash killed my screenshot the two times I tried, let me know if you can't reproduce this & I'll uninstall mono to reproduce again)

I no longer get this popup after sudo ports install mono

Thanks! :)

comment:4 Changed 6 years ago by ryandesign (Ryan Schmidt)

Oh, so you are talking about the mono port. I'm surprised that's used by wine. I'm also reluctant to add a dependency on mono, because it is huge, has historically had problems building and has been packaged poorly by its developers, and the port is unmaintained. I'll try to look into this and see if using the Wine Mono binary mentioned above would also work.

comment:5 in reply to:  description Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: jeremyhu@… added
Resolution: fixed
Status: newclosed

Replying to jodi.a.schneider@…:

I suggest adding Mono as a dependency. Mono is expected for Wine: http://wiki.winehq.org/Mono

This page says:

For Wine releases 1.5.3 and later, the Wine Mono package is recommended. For earlier versions, an official Windows release of Mono 2.10 is recommended.

Therefore, since all three wine packages are past version 1.6 already, in r128964 I've made the three wine ports use the wine mono package.

Note: See TracTickets for help on using tickets.