Opened 5 years ago

Closed 5 years ago

#44832 closed defect (fixed)

qemu @2.1.0_0+target_arm: build fails due to compiler errors using ${prefix}/include/utils.h from cdparanoia

Reported by: Polyergic (Shad Sterling) Owned by: raimue (Rainer Müller)
Priority: Normal Milestone:
Component: ports Version: 2.3.1
Keywords: Cc: jeremyhu (Jeremy Huddleston Sequoia)
Port: qemu cdparanoia

Description (last modified by larryv (Lawrence Velázquez))

OS X 10.9.4

Many errors from /opt/local/include/utils.h

Setting configure.compiler as suggested by bug #36475 or bug #36656 does not fix the problem.

I wonder if it's an #include problem like bug #25989; I do have the /opt/local/include/utils.h from cdparanoia. (Is this really a cdparanoia bug?)

It does not seem to depend on which other variants are selected; the attached log is with none.

Attachments (1)

main.log (464.9 KB) - added by Polyergic (Shad Sterling) 5 years ago.

Download all attachments as: .zip

Change History (10)

Changed 5 years ago by Polyergic (Shad Sterling)

Attachment: main.log added

comment:1 Changed 5 years ago by Polyergic (Shad Sterling)

Links to mentioned bugs: #36475, #36656; #25989

comment:2 in reply to:  description Changed 5 years ago by larryv (Lawrence Velázquez)

Cc: raimue@… openmaintainer@… removed
Description: modified (diff)
Owner: changed from macports-tickets@… to raimue@…
Summary: QEMU build fails with variant target_armqemu @2.1.0_0+target_arm: build fails due to compiler errors using ${prefix}/include/utils.h

FYI: “openmaintainer@macports.org” and “nomaintainer@macports.org” aren’t real email addresses.

comment:3 Changed 5 years ago by raimue (Rainer Müller)

Status: newassigned

Conflicting ports is definitely a bug. I will try to reproduce this and find a solution.

Deactivate the conflicting port temporarily as a workaround:

sudo port deactivate cdparanoia
sudo port clean qemu
sudo port install qemu +target_arm
sudo port activate cdparanoia

comment:4 Changed 5 years ago by raimue (Rainer Müller)

Cc: jeremyhu@… added
Port: cdparanoia added
Summary: qemu @2.1.0_0+target_arm: build fails due to compiler errors using ${prefix}/include/utils.hqemu @2.1.0_0+target_arm: build fails due to compiler errors using ${prefix}/include/utils.h from cdparanoia

Here are excerpts from a similar report for building QEMU inside Xen:

While we could try to reorder the includes locally, the upstream has a valid point that in other cases this might be required the other way around.

The real problem would be the generic naming of ${prefix}/include/utils.h from the cdparanoia port. Maybe we could move that into a subdirectory instead? I checked that at least Debian also ships that as /usr/include/utils.h, not sure about other distributions.

comment:5 in reply to:  3 Changed 5 years ago by Polyergic (Shad Sterling)

Replying to raimue@…:

The workaround got it installed, thanks!

comment:6 Changed 5 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Yeah... "utils.h" is way too generic for $prefix/include

comment:7 Changed 5 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Also, it looks like utils.h should be something internal to cdparanoia. I suggest we simply remove it.

comment:8 Changed 5 years ago by jeremyhu (Jeremy Huddleston Sequoia)

comment:9 Changed 5 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.