Opened 6 years ago

Closed 5 years ago

#44855 closed update (fixed)

OpenOCD @0.7: update to 0.8

Reported by: sprhawk@… Owned by: nerdling (Jeremy L)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: x.macports.org@…, ivo.clarysse@…
Port: openocd

Description

There are too many new features in OpenOCD 0.8

Attachments (2)

Portfile-openocd.diff (1.4 KB) - added by x.macports.org@… 6 years ago.
Openocd 0.8.0
openocd-0.8.0-libusb1-libftdi.patch (3.3 KB) - added by ivo.clarysse@… 5 years ago.
Update to OpenOCD-0.8, deprecating ft2xx variant in favor of ftdi variant

Download all attachments as: .zip

Change History (8)

comment:1 Changed 6 years ago by mf2k (Frank Schima)

Cc: snc@… removed
Keywords: openocd removed
Owner: changed from macports-tickets@… to snc@…
Type: requestupdate
Version: 2.3.1

Changed 6 years ago by x.macports.org@…

Attachment: Portfile-openocd.diff added

Openocd 0.8.0

comment:2 Changed 6 years ago by x.macports.org@…

Cc: x.macports.org@… added

Cc Me!

comment:3 Changed 5 years ago by petrrr

Summary: request port for OpenOCD 0.8OpenOCD @0.7: update to 0.8

comment:4 Changed 5 years ago by ivo.clarysse@…

Cc: ivo.clarysse@… added

Cc Me!

Changed 5 years ago by ivo.clarysse@…

Update to OpenOCD-0.8, deprecating ft2xx variant in favor of ftdi variant

comment:5 Changed 5 years ago by ivo.clarysse@…

Added an updated patch updating to OpenOCD 0.8 which retains the 'ft2232' variant as using libftdi (but using libftdi1 instead of libftdi0).

A new default 'ftdi' port variant is added using the built-in FTDI support using libusb-1.0.

Not done: May have to build openocd with HIDAPI support.

comment:6 Changed 5 years ago by nerdling (Jeremy L)

Resolution: fixed
Status: newclosed

I fixed the new variant's conflict's name, also added pkgconfig build dependency. r135644

Note: See TracTickets for help on using tickets.