Opened 7 years ago

Last modified 6 years ago

#45008 assigned submission

php-web

Reported by: Schamschula (Marius Schamschula) Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.3.1
Keywords: haspatch Cc: ctreleaven (Craig Treleaven), greg.schohn@…, diochnos
Port: php-web

Description

At this point php5-web is available, but no corresponding php56-web. I've edited the Portfile, see attached.

Also, note that the module names had to be fixed.

Attachments (1)

Portfile (1.7 KB) - added by Schamschula (Marius Schamschula) 7 years ago.

Download all attachments as: .zip

Change History (8)

Changed 7 years ago by Schamschula (Marius Schamschula)

Attachment: Portfile added

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

I would not want this port to be specific to PHP 5.6; it should work with PHP 5.3 through 5.6. To do this it could either use the php 1.1 portgroup, or could be a subport of the php port.

The check for an Apache 1 module is not useful because there is no way to install the new PHP ports as an Apache 1 module.

There should be a check for the FPM SAPI.

The message printed when a web server module is not found still mentions the old php5 port and variants; the new PHP ports don't use variants to enable different SAPIs, they use subports.

The reason I had not yet created this port is that I was not sure whether it should be specific to the PHP version or not. But making it version specific is certainly easier; I can't quite envision how it would work if it weren't.

comment:2 Changed 7 years ago by Schamschula (Marius Schamschula)

Fair enough. I just needed it to get squirrelmail installed…

comment:3 Changed 7 years ago by ctreleaven (Craig Treleaven)

Cc: ctreleaven@… added

Cc Me!

comment:4 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… removed
Owner: changed from macports-tickets@… to ryandesign@…
Port: php-web added; php56-web removed
Status: newassigned
Summary: php56-webphp-web

I have a version of this that I think I'm happy with, I just need to test a bit more.

comment:5 Changed 7 years ago by greg.schohn@…

Cc: greg.schohn@… added

Cc Me!

comment:6 Changed 6 years ago by micrology

Ryandesign said: "I have a version of this that I think I'm happy with, I just need to test a bit more." Any news about this? It would be good to be able to install mediawiki, which depends on this. thanks.

comment:7 Changed 6 years ago by diochnos

Cc: diochnos@… added

Cc Me!

Note: See TracTickets for help on using tickets.