Opened 6 years ago

Closed 6 years ago

#45111 closed defect (duplicate)

error when installing octave

Reported by: prowe@… Owned by: michaelld (Michael Dickens)
Priority: Normal Milestone:
Component: ports Version: 2.3.1
Keywords: Cc:
Port: octave

Description (last modified by larryv (Lawrence Velázquez))

I get the following error for >>sudo port install octave:

--->  Building octave
Error: org.macports.build for port octave returned: command execution failed
Please see the log file for port octave for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_octave/octave/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port octave failed

I'm on a new MacPro with Mavericks. Here are the steps I took:

  • Install Xcode
  • Open Xcode
  1. Type xcode-select --install
  2. Install Macports on Mac
    https://www.macports.org/install.php
    Click on “OS X 10.9 Mavericks” for automatic download.
  3. Type “sudo port install hdf5
  4. Type “sudo port install netcdf
  5. Type “sudo port install netcdf-cxx” for C++ interface
  6. Type “sudo port install netcdf-fortran” for Fortran interface
  7. Type “sudo port install libgcc
  8. Type “sudo port install gcc47
    Couldn’t successful load “atlas” package using either gcc49 or gcc48.
    So tried to follow this
    #40542
  9. Type “sudo port clean atlas
  10. Type “sudo port -v install atlas +gcc47
  11. Type “sudo port install octave

Thank you for any help!

Attachments (1)

main.log (563.5 KB) - added by prowe@… 6 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 6 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Owner: changed from macports-tickets@… to michaelld@…
Port: octave added

Please attach the main.log file.

comment:2 Changed 6 years ago by larryv (Lawrence Velázquez)

Description: modified (diff)

I would expect you’d need to specify a GCC variant for hdf5, netcdf, netcdf-cxx, and netcdf-fortran, at the very least.

Changed 6 years ago by prowe@…

Attachment: main.log added

comment:3 Changed 6 years ago by prowe@…

Why would I need to specify a gcc variant?

The steps I took worked fine for my colleague, I think on a Mac Air, except for the atlas part as outlined in the steps. It worked fine on my Mac laptop (and no atlas problems there).

Last edited 6 years ago by prowe@… (previous) (diff)

comment:4 in reply to:  3 Changed 6 years ago by larryv (Lawrence Velázquez)

Replying to prowe@…:

Why would I need to specify a gcc variant?

You cannot mix C++ runtimes. Binaries built with clang++ / libc++abi should not link against binaries built with g++ / libsupc++. Even if they link “properly”, you will experience runtime issues and crashes.

comment:5 Changed 6 years ago by prowe@…

I'm new at this; do I specify a gcc variant by appending +gcc47; e.g. sudo port install hdf5 +gcc47? Should I also append a -clang?

Thanks so much for your help!

comment:6 Changed 6 years ago by prowe@…

I tried uninstalling everything and reinstalling with +gcc47 for hdf5, netcdf, netcdf-cxx, and netcdf-fortran, but that did not work. I think the error message at the end was the same.

Next I uninstalled everything again and reinstalled with +gcc47 and - any default variants (which I found using sudo port variants). Same error message. The main.log file differs only slightly.

comment:7 Changed 6 years ago by mf2k (Frank Schima)

Why are you using gcc47? Try gcc48 which is the default in Macports. Also I would suggested re-installing ld64 and cctools since they recently changed default variants to use llvm-3.5.

As far as hdf5 goes, there is no "clang" variant so there is no need to specify "-clang".

FYI, since Trac is not for tech support, follow-up on the Macports Users mailing list instead and you will get a much wider audience to help you.

comment:8 Changed 6 years ago by michaelld (Michael Dickens)

Can you try:

sudo port clean octave
sudo port install octave

and see if that helps. If not, what does "xcodebuild -version" return for you? I'm wondering if this might be a result of Xcode 6 ... which I don't have yet.

comment:9 Changed 6 years ago by Schamschula (Marius Schamschula)

The main.log file says it all: a duplicate of #45011 - Xcode 6.0.1 issue.

comment:10 Changed 6 years ago by michaelld (Michael Dickens)

Resolution: duplicate
Status: newclosed

Thanks; I'm closing this one & will work on the other ticket instead.

Note: See TracTickets for help on using tickets.