Opened 6 years ago

Closed 6 years ago

#45234 closed defect (fixed)

Checksum (sha1) mismatch for bash43-028

Reported by: steven@… Owned by: raimue (Rainer Müller)
Priority: Normal Milestone:
Component: ports Version: 2.3.1
Keywords: Cc: skymoo (Adam Mercer), sierkb@…
Port: bash

Description

mac:~# port clean --all outdated
--->  Cleaning bash
mac:~# port upgrade outdated
--->  Computing dependencies for bash
--->  Fetching archive for bash
--->  Attempting to fetch bash-4.3.28_0.darwin_10.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/bash
--->  Attempting to fetch bash-4.3.28_0.darwin_10.x86_64.tbz2 from http://nue.de.packages.macports.org/macports/packages/bash
--->  Attempting to fetch bash-4.3.28_0.darwin_10.x86_64.tbz2 from http://lil.fr.packages.macports.org/bash
--->  Fetching distfiles for bash
--->  Attempting to fetch bash43-001 from http://www.mirrorservice.org/sites/ftp.gnu.org/gnu/bash/bash-4.3-patches
--->  Attempting to fetch bash43-002 from http://www.mirrorservice.org/sites/ftp.gnu.org/gnu/bash/bash-4.3-patches
--->  Attempting to fetch bash43-003 from http://www.mirrorservice.org/sites/ftp.gnu.org/gnu/bash/bash-4.3-patches
--->  Attempting to fetch bash43-004 from http://www.mirrorservice.org/sites/ftp.gnu.org/gnu/bash/bash-4.3-patches
--->  Attempting to fetch bash43-005 from http://www.mirrorservice.org/sites/ftp.gnu.org/gnu/bash/bash-4.3-patches
--->  Attempting to fetch bash43-006 from http://www.mirrorservice.org/sites/ftp.gnu.org/gnu/bash/bash-4.3-patches
--->  Attempting to fetch bash43-007 from http://www.mirrorservice.org/sites/ftp.gnu.org/gnu/bash/bash-4.3-patches
--->  Attempting to fetch bash43-008 from http://www.mirrorservice.org/sites/ftp.gnu.org/gnu/bash/bash-4.3-patches
--->  Attempting to fetch bash43-009 from http://www.mirrorservice.org/sites/ftp.gnu.org/gnu/bash/bash-4.3-patches
--->  Attempting to fetch bash43-010 from http://www.mirrorservice.org/sites/ftp.gnu.org/gnu/bash/bash-4.3-patches
--->  Attempting to fetch bash43-011 from http://www.mirrorservice.org/sites/ftp.gnu.org/gnu/bash/bash-4.3-patches
--->  Attempting to fetch bash43-012 from http://www.mirrorservice.org/sites/ftp.gnu.org/gnu/bash/bash-4.3-patches
--->  Attempting to fetch bash43-013 from http://www.mirrorservice.org/sites/ftp.gnu.org/gnu/bash/bash-4.3-patches
--->  Attempting to fetch bash43-014 from http://www.mirrorservice.org/sites/ftp.gnu.org/gnu/bash/bash-4.3-patches
--->  Attempting to fetch bash43-015 from http://www.mirrorservice.org/sites/ftp.gnu.org/gnu/bash/bash-4.3-patches
--->  Attempting to fetch bash43-016 from http://www.mirrorservice.org/sites/ftp.gnu.org/gnu/bash/bash-4.3-patches
--->  Attempting to fetch bash43-017 from http://www.mirrorservice.org/sites/ftp.gnu.org/gnu/bash/bash-4.3-patches
--->  Attempting to fetch bash43-018 from http://www.mirrorservice.org/sites/ftp.gnu.org/gnu/bash/bash-4.3-patches
--->  Attempting to fetch bash43-019 from http://www.mirrorservice.org/sites/ftp.gnu.org/gnu/bash/bash-4.3-patches
--->  Attempting to fetch bash43-020 from http://www.mirrorservice.org/sites/ftp.gnu.org/gnu/bash/bash-4.3-patches
--->  Attempting to fetch bash43-021 from http://www.mirrorservice.org/sites/ftp.gnu.org/gnu/bash/bash-4.3-patches
--->  Attempting to fetch bash43-022 from http://www.mirrorservice.org/sites/ftp.gnu.org/gnu/bash/bash-4.3-patches
--->  Attempting to fetch bash43-023 from http://www.mirrorservice.org/sites/ftp.gnu.org/gnu/bash/bash-4.3-patches
--->  Attempting to fetch bash43-024 from http://www.mirrorservice.org/sites/ftp.gnu.org/gnu/bash/bash-4.3-patches
--->  Attempting to fetch bash43-025 from http://www.mirrorservice.org/sites/ftp.gnu.org/gnu/bash/bash-4.3-patches
--->  Attempting to fetch bash43-026 from http://www.mirrorservice.org/sites/ftp.gnu.org/gnu/bash/bash-4.3-patches
--->  Attempting to fetch bash43-027 from http://www.mirrorservice.org/sites/ftp.gnu.org/gnu/bash/bash-4.3-patches
--->  Attempting to fetch bash43-028 from http://www.mirrorservice.org/sites/ftp.gnu.org/gnu/bash/bash-4.3-patches
--->  Attempting to fetch bash43-028 from http://mse.uk.distfiles.macports.org/sites/distfiles.macports.org/bash
--->  Attempting to fetch bash43-028 from ftp://ftp.lip6.fr/pub/gnu/bash/bash-4.3-patches
--->  Attempting to fetch bash43-028 from http://lil.fr.distfiles.macports.org/bash
--->  Attempting to fetch bash43-028 from http://nue.de.distfiles.macports.org/macports/distfiles/bash
--->  Attempting to fetch bash43-028 from http://fco.it.distfiles.macports.org/mirrors/macports-distfiles/bash
--->  Attempting to fetch bash43-028 from ftp://ftp.funet.fi/pub/gnu/prep/bash/bash-4.3-patches
--->  Attempting to fetch bash43-028 from http://her.gr.distfiles.macports.org/mirrors/macports/mpdistfiles/bash
--->  Attempting to fetch bash43-028 from http://mirrors.ibiblio.org/gnu/ftp/gnu/bash/bash-4.3-patches
--->  Attempting to fetch bash-4.3.tar.gz from http://www.mirrorservice.org/sites/ftp.gnu.org/gnu/bash
--->  Verifying checksums for bash
Error: Checksum (sha1) mismatch for bash43-028
Error: org.macports.checksum for port bash returned: Unable to verify file checksums
Please see the log file for port bash for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_shells_bash/bash/main.log
Error: Unable to upgrade port: 1
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Mac-mini-van-Steven-Van-Ingelgem:~# less /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_shells_bash/bash/main.log

Attachments (2)

main.log (19.6 KB) - added by steven@… 6 years ago.
/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_shells_bash/bash/main.log
bash43-028 (68.3 KB) - added by steven@… 6 years ago.
/opt/local/var/macports/distfiles/bash/bash43-028

Download all attachments as: .zip

Change History (11)

Changed 6 years ago by steven@…

Attachment: main.log added

/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_shells_bash/bash/main.log

comment:1 Changed 6 years ago by skymoo (Adam Mercer)

Cc: ram@… added

Cc Me!

comment:2 Changed 6 years ago by skymoo (Adam Mercer)

Owner: changed from macports-tickets@… to raimue@…

comment:3 Changed 6 years ago by sierkb@…

Cc: sierkb@… added

Cc Me!

comment:4 Changed 6 years ago by raimue (Rainer Müller)

I've got the same report from the build bots, but I can't reproduce the problem locally. According to the GnuPG signature (which I also verified before generating the checksum), the one currently in the Portfile is correct – or at least, it is really a patch released by Chet Ramey.

What is the contents of the file with the different checksum? I also tried the steps below with the mirror URLs from your main.log and I get the exact same file from both.

raimue@eunomia ~ $ wget http://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-028.sig
[...]
raimue@eunomia ~ $ wget http://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-028
[...]
raimue@eunomia ~ $ gpg --verify bash43-028.sig
gpg: Signature made Wed Oct  1 19:23:01 2014 CEST using DSA key ID 64EA74AB
gpg: Good signature from "Chet Ramey <chet@cwru.edu>"
gpg: WARNING: This key is not certified with a trusted signature!
gpg:          There is no indication that the signature belongs to the owner.
Primary key fingerprint: 7C01 35FB 088A AF6C 66C6  50B9 BB58 69F0 64EA 74AB
raimue@eunomia ~ $ sha1sum bash43-028
1e05d95e4abd32b631d991fa374d030c1651645d  bash43-028

comment:5 Changed 6 years ago by steven@…

Mac-mini-van-Steven-Van-Ingelgem:~ steven$ cd /opt/local/var/macports/distfiles/bash
Mac-mini-van-Steven-Van-Ingelgem:bash steven$ ls -l bash43-028
-rw-r--r--  1 macports  admin  69926 Oct  1 20:24 bash43-028
Mac-mini-van-Steven-Van-Ingelgem:bash steven$ head bash43-028
                             BASH PATCH REPORT
                             =================

Bash-Release:   4.3
Patch-ID:       bash43-028

Bug-Reported-by:        Florian Weimer <fweimer@redhat.com>
Bug-Reference-ID:
Bug-Reference-URL:

Mac-mini-van-Steven-Van-Ingelgem:bash steven$ tail bash43-028

! #define PATCHLEVEL 27

  #endif /* _PATCHLEVEL_H_ */
--- 26,30 ----
     looks for to find the patch level (for the sccs version string). */

! #define PATCHLEVEL 28

  #endif /* _PATCHLEVEL_H_ */

This is what I got:

Mac-mini-van-Steven-Van-Ingelgem:~ steven$ sha1sum ~/bash43-028* /opt/local/var/macports/distfiles/bash/bash43-028
1e05d95e4abd32b631d991fa374d030c1651645d  /Users/steven/bash43-028
178010874177f505d782a94af4e43100ac9ef06f  /Users/steven/bash43-028.sig
0cb3ff195fb252ff4bd33f7562c4e1917b210edc  /opt/local/var/macports/distfiles/bash/bash43-028

Changed 6 years ago by steven@…

Attachment: bash43-028 added

/opt/local/var/macports/distfiles/bash/bash43-028

comment:6 Changed 6 years ago by raimue (Rainer Müller)

It seems like the patch was uploaded with different paths in the chunks first, but is otherwise identical.

As a workaround, use the following command:

$ sudo port clean --all bash

I also retriggered the buildbots, let's see if it works this time.

comment:7 Changed 6 years ago by steven@…

No such luck:

Mac-mini-van-Steven-Van-Ingelgem:~ steven$ sudo port clean --all bash
Password:
--->  Cleaning bash
Mac-mini-van-Steven-Van-Ingelgem:~ steven$ sudo port upgrade bash
--->  Computing dependencies for bash
--->  Fetching archive for bash
--->  Attempting to fetch bash-4.3.28_0.darwin_10.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/bash
--->  Attempting to fetch bash-4.3.28_0.darwin_10.x86_64.tbz2 from http://nue.de.packages.macports.org/macports/packages/bash
--->  Attempting to fetch bash-4.3.28_0.darwin_10.x86_64.tbz2 from http://lil.fr.packages.macports.org/bash
--->  Attempting to fetch bash-4.3.28_0.darwin_10.x86_64.tbz2.rmd160 from http://lil.fr.packages.macports.org/bash
Error: org.macports.archivefetch for port bash returned: Failed to fetch signature for archive: Empty reply from server
Please see the log file for port bash for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_shells_bash/bash/main.log
Error: Unable to upgrade port: 1
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets

comment:8 Changed 6 years ago by steven@…

Sorry, that was too fast. I re-did that and now it looks good:

Mac-mini-van-Steven-Van-Ingelgem:~ steven$ sudo port upgrade bash
--->  Computing dependencies for bash
--->  Fetching archive for bash
--->  Attempting to fetch bash-4.3.28_0.darwin_10.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/bash
--->  Attempting to fetch bash-4.3.28_0.darwin_10.x86_64.tbz2 from http://nue.de.packages.macports.org/macports/packages/bash
--->  Attempting to fetch bash-4.3.28_0.darwin_10.x86_64.tbz2 from http://lil.fr.packages.macports.org/bash
--->  Attempting to fetch bash-4.3.28_0.darwin_10.x86_64.tbz2.rmd160 from http://lil.fr.packages.macports.org/bash
--->  Installing bash @4.3.28_0
--->  Cleaning bash
--->  Computing dependencies for bash
--->  Deactivating bash @4.3.27_0
--->  Cleaning bash
--->  Activating bash @4.3.28_0
--->  Cleaning bash
--->  Updating database of binaries
--->  Scanning binaries for linking errors
--->  No broken files found.

comment:9 Changed 6 years ago by raimue (Rainer Müller)

Resolution: fixed
Status: newclosed

Yes, you got the pre-compiled binary package now. Anyone else experiencing this issue should please also do the sudo port clean --all bash and then try again.

Note: See TracTickets for help on using tickets.