Opened 6 years ago

Closed 6 years ago

#45293 closed defect (fixed)

gcr @3.14.0_0 fails to link on 10.5.8 PPC

Reported by: udbraumann Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 2.3.1
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: gcr

Description

I was unable to upgrade gcr from 3.12.2_1 to 3.14.0_0 due to problems while linking:

...
:info:build Undefined symbols:
:info:build   "_gcr_dbus_prompter_callback_skeleton_get_type", referenced from:
:info:build       __gcr_dbus_prompter_callback_skeleton_new in libgcr_base_3_la-gcr-dbus-generated.o
:info:build       ___gcr_dbus_prompter_callback_skeleton_handle_set_property in libgcr_base_3_la-gcr-dbus-generated.o
:info:build       ___gcr_dbus_prompter_callback_skeleton_handle_get_property in libgcr_base_3_la-gcr-dbus-generated.o
...

Attachments (1)

main.log (264.0 KB) - added by udbraumann 6 years ago.
build log

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by udbraumann

Attachment: main.log added

build log

comment:1 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: devans@… openmaintainer@… removed
Keywords: undefined symbol during linking removed
Owner: changed from macports-tickets@… to devans@…

comment:2 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added

Cc Me!

comment:3 Changed 6 years ago by jeremyhu (Jeremy Huddleston Sequoia)

This isn't limited to Leopard/ppc. The issue also happened to me updating from gcr @3.12.2_1+universal on Mavericks. The issue doesn't seem to be caused by having an older version of gcr installed at the time of upgrade as I first thought. It seems that the missing symbols should have been provided by gcr/gcr-dbus-generated.c which is generated code (by gdbus-codegen).

comment:4 Changed 6 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Yeah, looks like a bug in the build system... shouldn't be too hard to fix it up.

comment:5 Changed 6 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.