Opened 5 years ago

Closed 5 years ago

#45424 closed defect (fixed)

kfilemetadata does not allow ffmpeg-devel as a dependency

Reported by: mf2k (Frank Schima) Owned by: NicosPavlov
Priority: Normal Milestone:
Component: ports Version: 2.3.99
Keywords: Cc:
Port: kfilemetadata

Description

For some reason, nepomuk-core no longer allows ffmpeg-devel to satisfy the dependency for ffmpeg.

$ port installed ffmpeg*
The following ports are currently installed:
  ffmpeg-devel @20141005_0+gpl2+nonfree+x11 (active)

$ port outdated 
The following installed ports are outdated:
nepomuk-core                   4.12.5_1 < 4.13.3_0       

$ sudo port upgrade outdated 
--->  Computing dependencies for ffmpeg
Error: Unable to exec port: Can't install ffmpeg because conflicting ports are active: ffmpeg-devel
Error: Follow http://guide.macports.org/#project.tickets to report a bug.

Change History (2)

comment:1 Changed 5 years ago by ryandesign (Ryan Schmidt)

Port: kfilemetadata added; nepomuk-core removed
Summary: nepomuk-core does not allow ffmpeg-devel as a dependencykfilemetadata does not allow ffmpeg-devel as a dependency

Actually, it's nepomuk-core's new dependency kfilemetadata that doesn't allow ffmpeg-devel.

comment:2 Changed 5 years ago by NicosPavlov

Resolution: fixed
Status: newclosed

Thanks for the correction. Committed in r126955.

Note: See TracTickets for help on using tickets.