Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#45433 closed defect (duplicate)

CMake fails to build with Xcode 6.

Reported by: atzimler (Attila Tamas Zimler) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.1
Keywords: yosemite Cc:
Port: cmake

Description

I ran into the same situation with as ticket:44210.

CMake failed to build on the pure Yosemite install, with Xcode 6. I tried every proposed solution from the ticket referred, but none of them worked.

Then I figured out that the Xcode 6 installed with Yosemite contains

/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.9.sdk

directory, instead of the one that CMake would like to refer (ending MacOSX10.10.sdk). By symlinking the existing directory to

/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.10.sdk

CMake is able to compile. I don't know why the original bug report was closed as there seems to be no solution on the page.

Change History (3)

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Keywords: yosemite added
Port: cmake added
Resolution: duplicate
Status: newclosed

Duplicate of #44581. Install and select Xcode 6.1.

comment:2 Changed 7 years ago by ryandesign (Ryan Schmidt)

And please remove the symlink you created.

comment:3 Changed 7 years ago by atzimler (Attila Tamas Zimler)

If I would install the new version of Xcode, then it would remove the symlink - since it's inside the app bundle. The problem with using the 6.1 is that I need the stable version for development purposes.

Maybe CMake should make decision on where the SDKs are located not based on the OS version, but based on the Xcode version if we are looking into the Xcode app's internal stuff.

Last edited 7 years ago by atzimler (Attila Tamas Zimler) (previous) (diff)
Note: See TracTickets for help on using tickets.