Opened 3 years ago

Closed 2 years ago

#45445 closed defect (fixed)

gimp-app @2.8.2_2: iPhoneSimulator: SimVerifier returned: Error Domain=NSPOSIXErrorDomain Code=53 "Simulator verification failed."

Reported by: adam.bartley@… Owned by: macports-tickets@…
Priority: High Milestone:
Component: ports Version: 2.3.1
Keywords: yosemite Cc: ryandesign (Ryan Schmidt), Dmole (Tim)
Port:

Description

This one fails because, according to the error log, it is looking for the iphone simulator in XCode. Can think of no good reason why it should be doing this. While I am trying to install said simulator now, perhaps someone could look into why the package is trying to do this?

Attachments (3)

main.log (2.9 KB) - added by adam.bartley@… 3 years ago.
main.2.log (226.3 KB) - added by Dmole (Tim) 3 years ago.
appify.sh (452 bytes) - added by Dmole (Tim) 3 years ago.

Download all attachments as: .zip

Change History (30)

Changed 3 years ago by adam.bartley@…

comment:1 Changed 3 years ago by ryandesign (Ryan Schmidt)

  • Cc ryandesign@… added
  • Priority changed from Normal to High
  • Summary changed from gimp-app @2.8.2_2 build failure to gimp-app @2.8.2_2: iPhoneSimulator: SimVerifier returned

Many ports are failing this way under Xcode 6.1, e.g. graphviz-gui. You can work around the problem by downloading and "xcode-select"ing Xcode 6.0. If you are on OS X 10.10 Yosemite, be sure to re-select Xcode 6.1 afterward as it is required for other ports on Yosemite.

comment:2 follow-up: Changed 3 years ago by ryandesign (Ryan Schmidt)

So I was finally trying to investigate this problem by running the commands outside of MacPorts, and the problem went away for me in MacPorts. What happens if you just run xcodebuild on the command line, and then try installing this port again?

comment:3 in reply to: ↑ 2 Changed 3 years ago by Dmole (Tim)

Replying to ryandesign@…:

So I was finally trying to investigate this problem by running the commands outside of MacPorts, and the problem went away for me in MacPorts. What happens if you just run xcodebuild on the command line, and then try installing this port again?

xcodebuild
xcodebuild: error: The directory /Users/user does not contain an Xcode project.

anything else to try?

Last edited 3 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:4 follow-up: Changed 3 years ago by ryandesign (Ryan Schmidt)

And after encountering that error, does the port then work, or does it still fail with the same error?

comment:5 in reply to: ↑ 4 Changed 3 years ago by Dmole (Tim)

Replying to ryandesign@…:

And after encountering that error, does the port then work, or does it still fail with the same error?

It still fails I think I need to upgrade iOS from 6 to 7... odd but whatever, downloading it now...

comment:6 Changed 3 years ago by Dmole (Tim)

  • Cc elatllat@… added

Cc Me!

comment:7 Changed 3 years ago by Dmole (Tim)

see #44057

Last edited 3 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:8 follow-up: Changed 3 years ago by ryandesign (Ryan Schmidt)

That ticket has nothing to do with this ticket, but I see you've added comments to the end of it discussing this issue. So, are you saying that after opening Xcode.app once, you're now able to build gimp-app?

comment:9 in reply to: ↑ 8 ; follow-up: Changed 3 years ago by Dmole (Tim)

Replying to ryandesign@…:

That ticket has nothing to do with this ticket, but I see you've added comments to the end of it discussing this issue. So, are you saying that after opening Xcode.app once, you're now able to build gimp-app?

Both tickets contain the string 'iPhoneSimulator: SimVerifier returned: Error Domain=NSPOSIXErrorDomain Code=53 "Simulator verification failed."' (the only 2 Google hits) so they may bre related.

No I am not able to build (osxfuse in my case)..

iOS 7 did not help as it already came with ios8. More goggling for why iOS simulator won't start....

comment:10 Changed 3 years ago by Dmole (Tim)

Looks like the simulator (like XCode itself) just took a long time to boot on the first run.

So after getting the simulator working that "Simulator verification failed" bug sees to be fixed. I get a different bug I'll post about where appropriate.

Last edited 3 years ago by Dmole (Tim) (previous) (diff)

comment:11 in reply to: ↑ 9 ; follow-up: Changed 3 years ago by ryandesign (Ryan Schmidt)

Replying to elatllat@…:

Replying to ryandesign@…:

That ticket has nothing to do with this ticket, but I see you've added comments to the end of it discussing this issue. So, are you saying that after opening Xcode.app once, you're now able to build gimp-app?

Both tickets contain the string 'iPhoneSimulator: SimVerifier returned: Error Domain=NSPOSIXErrorDomain Code=53 "Simulator verification failed."' (the only 2 Google hits) so they may bre related.

Someone added this unrelated error message to that bug yesterday. It is not relevant to that ticket.

iOS 7 did not help as it already came with ios8. More goggling for why iOS simulator won't start....

Nothing in MacPorts has anything to do with the iOS simulator.

comment:12 in reply to: ↑ 11 Changed 3 years ago by Dmole (Tim)

Replying to ryandesign@…:

... Nothing in MacPorts has anything to do with the iOS simulator.

Maybe not directly but macports uses xcode and xcode for whatever reason needs the simulator initialized to build (some?) projects (that don't have the simulator as a destination?).

comment:13 follow-ups: Changed 3 years ago by jeremyhu (Jeremy Huddleston Sequoia)

The initial launch of Xcode does some things including checking (and possibly fixing) permissions on dyld_sim in the iOS Simulator.

Your launch of Xcode by your "real " user fixed it such that the verifier service was not needed when run later by the macports user (the service is only used to fix issues if needed).

I'm curious why this failure was happening, so can you please send me the relevant CoreSimulator logs from both your user and the macports user as well as the host syslog at the time of the failure?

comment:14 in reply to: ↑ 13 Changed 3 years ago by Dmole (Tim)

After running the simulator as a real user gimp-app will get a lot further in the build script 3031 vs 24 lines of log.

the next bug in the build seems related to #45475

gimp2 installs fine so I'm using that and appify.sh for now.

Last edited 3 years ago by Dmole (Tim) (previous) (diff)

Changed 3 years ago by Dmole (Tim)

Changed 3 years ago by Dmole (Tim)

comment:15 in reply to: ↑ 13 Changed 3 years ago by Dmole (Tim)

Replying to jeremyhu@…: ...logs...

file ~/Library/Logs/CoreSimulator/iOS\ Simulator.log

~/Library/Logs/CoreSimulator/iOS Simulator.log: empty

There are no logs from the relevant time in CoreSimulator.log

grep "Oct 19 18:54" ~/Library/Logs/CoreSimulator/CoreSimulator.log

see #44057 for system.log

Last edited 3 years ago by Dmole (Tim) (previous) (diff)

comment:16 Changed 3 years ago by ryandesign (Ryan Schmidt)

  • Keywords yosemite added

comment:17 Changed 3 years ago by ryandesign (Ryan Schmidt)

  • Summary changed from gimp-app @2.8.2_2: iPhoneSimulator: SimVerifier returned to gimp-app @2.8.2_2: iPhoneSimulator: SimVerifier returned: Error Domain=NSPOSIXErrorDomain Code=53 "Simulator verification failed."

See also #45516, same problem reported for aquaterm.

comment:18 Changed 3 years ago by jeremyhu (Jeremy Huddleston Sequoia)

  • Resolution set to worksforme
  • Status changed from new to closed

<rdar://problem/18720815>

comment:19 follow-up: Changed 3 years ago by Dmole (Tim)

What, it's only a bug if it effects everyone?

comment:20 in reply to: ↑ 19 Changed 3 years ago by larryv (Lawrence Velázquez)

It’s an Xcode bug that’s been reported to Apple internally (hence the Radar URL). There’s nothing else we can do on the outside.

comment:21 Changed 3 years ago by Dmole (Tim)

Thanks for the clarification...so "worksforme" should be "cantfix"...

comment:22 Changed 3 years ago by ryandesign (Ryan Schmidt)

  • Resolution worksforme deleted
  • Status changed from closed to reopened

This is definitely not "worksforme". Let's keep it open until a fix is released.

comment:23 Changed 3 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Yes, it's not "worksforme", but we unfortunately don't have an "it's not our problem, someone else needs to fix it" resolution, so I just picked one at random. Perhaps "invalid" or "wontfix" would've been better.

comment:24 follow-up: Changed 3 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Can someone that is reproducing this issue and has access to Xcode 6.3 beta 4 please test the current release and let me know if this is still a problem for you? Things have changed to xcodebuild which make me think this may be addressed.

comment:25 Changed 3 years ago by oleksii.taran@…

While I haven't tried to reproduce this exact issue, I do see this error when I build my projects on both Xcode 6.2 and Xcode 6.3 beta 4. There is a workaround: after I have wiped /Library/Developer/CoreSimulator, everything is working.

comment:26 in reply to: ↑ 24 Changed 3 years ago by ryandesign (Ryan Schmidt)

Replying to jeremyhu@…:

Can someone that is reproducing this issue and has access to Xcode 6.3 beta 4 please test the current release and let me know if this is still a problem for you? Things have changed to xcodebuild which make me think this may be addressed.

The problem remains with Xcode 6.3.1. The problem recurs every time I update Xcode.app. I have filed rdar://20694363

comment:27 Changed 2 years ago by jeremyhu (Jeremy Huddleston Sequoia)

  • Resolution set to fixed
  • Status changed from reopened to closed

The 6.3.1 issue was due to identifiers being incorrect but could be worked around by just launching iOS Simulator.app or Xcode.app to trigger the change. Xcode 7 fixed that.

Also, OS X 10.10.5 and 10.11 no longer requires this.

There's no reason to keep this ticket open.

Note: See TracTickets for help on using tickets.