Opened 8 years ago

Closed 8 years ago

#45517 closed defect (fixed)

llvm-3.5 @3.5-r216817_0: cannot connect to Subversion repository

Reported by: kzeroyu@… Owned by: jeremyhu (Jeremy Huddleston Sequoia)
Priority: Normal Milestone:
Component: ports Version: 2.3.2
Keywords: Cc: qasdfgtyuiop@…, larryv (Lawrence Velázquez)
Port: llvm-3.5

Description (last modified by larryv (Lawrence Velázquez))

--->  Computing dependencies for llvm-3.5
--->  Fetching archive for llvm-3.5
--->  Attempting to fetch llvm-3.5-3.5-r216817_0+assertions.darwin_14.x86_64.tbz2 from http://packages.macports.org/llvm-3.5
--->  Attempting to fetch llvm-3.5-3.5-r216817_0+assertions.darwin_14.x86_64.tbz2 from http://lil.fr.packages.macports.org/llvm-3.5
--->  Attempting to fetch llvm-3.5-3.5-r216817_0+assertions.darwin_14.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/llvm-3.5
--->  Fetching distfiles for llvm-3.5
Error: org.macports.fetch for port llvm-3.5 returned: Subversion check out failed
Please see the log file for port llvm-3.5 for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_llvm-3.5/llvm-3.5/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port llvm-3.5 failed

Attachments (1)

main.log (33.8 KB) - added by kzeroyu@… 8 years ago.

Download all attachments as: .zip

Change History (21)

Changed 8 years ago by kzeroyu@…

Attachment: main.log added

comment:1 Changed 8 years ago by larryv (Lawrence Velázquez)

Description: modified (diff)
Port: llvm-3.5 added

Did you interrupt a previous fetch? Try running sudo port clean llvm-3.5 && sudo port install llvm-3.5.

comment:2 in reply to:  1 ; Changed 8 years ago by kzeroyu@…

Replying to larryv@…:

Did you interrupt a previous fetch? Try running sudo port clean llvm-3.5 && sudo port install llvm-3.5.

I tried but did not work.

comment:3 in reply to:  2 Changed 8 years ago by larryv (Lawrence Velázquez)

Owner: changed from macports-tickets@… to jeremyhu@…
Summary: llvm@3.5 fetch error - build failurellvm-3.5 @3.5-r216817_0: cannot connect to Subversion repository
:debug:fetch Executing command line:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_llvm-3.5/llvm-3.5/work" && /usr/bin/svn --non-interactive --trust-server-cert export http://llvm.org/svn/llvm-project/llvm/branches/release_35@216817 2>&1
:info:fetch svn: E175002: Unable to connect to a repository at URL 'http://llvm.org/svn/llvm-project/llvm/branches/release_35'
:info:fetch svn: E175002: OPTIONS of 'http://llvm.org/svn/llvm-project/llvm/branches/release_35': Could not read status line: connection was closed by server (http://llvm.org)
:info:fetch Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_llvm-3.5/llvm-3.5/work" && /usr/bin/svn --non-interactive --trust-server-cert export http://llvm.org/svn/llvm-project/llvm/branches/release_35@216817 2>&1
:info:fetch Exit code: 1

comment:4 Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: qasdfgtyuiop@… added

Has duplicate #45554.

The port should be changed to fetch from a distfile to avoid this kind of problem. See #44938.

comment:5 Changed 8 years ago by cdeil (Christoph Deil)

I see the same error after updating to Yosemite and doing a fresh Macports install.

$ sudo port clean llvm-3.5
--->  Cleaning llvm-3.5
$ sudo port install llvm-3.5
--->  Computing dependencies for llvm-3.5
--->  Fetching archive for llvm-3.5
--->  Attempting to fetch llvm-3.5-3.5-r216817_0+assertions.darwin_14.x86_64.tbz2 from http://nue.de.packages.macports.org/macports/packages/llvm-3.5
--->  Attempting to fetch llvm-3.5-3.5-r216817_0+assertions.darwin_14.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/llvm-3.5
--->  Attempting to fetch llvm-3.5-3.5-r216817_0+assertions.darwin_14.x86_64.tbz2 from http://lil.fr.packages.macports.org/llvm-3.5
--->  Fetching distfiles for llvm-3.5
Error: org.macports.fetch for port llvm-3.5 returned: Subversion check out failed
Please see the log file for port llvm-3.5 for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_llvm-3.5/llvm-3.5/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port llvm-3.5 failed

Full log here: https://gist.github.com/cdeil/3e628a2f9aedf10b6ff2

Is there a known workaround or fix?

comment:6 Changed 8 years ago by cdeil (Christoph Deil)

Using https instead of http works:

$ /usr/bin/svn --non-interactive --trust-server-cert export http://llvm.org/svn/llvm-project/llvm/branches/release_35@216817
svn: E175002: Unable to connect to a repository at URL 'http://llvm.org/svn/llvm-project/llvm/branches/release_35'
svn: E175002: OPTIONS of 'http://llvm.org/svn/llvm-project/llvm/branches/release_35': Could not read status line: connection was closed by server (http://llvm.org)
$ svn --non-interactive --trust-server-cert export http://llvm.org/svn/llvm-project/llvm/branches/release_35@216817
svn: E120108: Unable to connect to a repository at URL 'http://llvm.org/svn/llvm-project/llvm/branches/release_35'
svn: E120108: Error running context: The server unexpectedly closed the connection.
$ /usr/bin/svn --non-interactive --trust-server-cert export https://llvm.org/svn/llvm-project/llvm/branches/release_35@216817
A    release_35
...

Searching for that error message I found a few posts that suggest to use https:

But I'm not actually sure what the problem is, i.e. why using http works for some users, but not for others.

comment:7 Changed 8 years ago by ryandesign (Ryan Schmidt)

Has duplicate #45770.

comment:8 Changed 8 years ago by wnowak1@…

Does anyone have a working workaround for this issue? Thanks.

comment:9 in reply to:  8 ; Changed 8 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Replying to wnowak1@…:

Does anyone have a working workaround for this issue? Thanks.

See comment #6

comment:10 in reply to:  9 ; Changed 8 years ago by wnowak1@…

Replying to jeremyhu@…:

Replying to wnowak1@…:

Does anyone have a working workaround for this issue? Thanks.

See comment #6

Sorry, the comment is not very clear to me on what the workaround is. Is there another tutorial?

comment:11 in reply to:  10 Changed 8 years ago by larryv (Lawrence Velázquez)

Try editing the Portfile and changing the “http:” in svn.url to “https:”.

$ sudo port edit llvm-3.5

comment:12 Changed 8 years ago by lou@…

There seems to be an issue with llvm.org, The checkout fails. I modified my portfile to use the git mirror for llvm at https://github.com/llvm-mirror/llvm:

fetch.type              git
#svn.revision            216817
#svn.url                 http://llvm.org/svn/llvm-project/llvm/branches/release_${llvm_version_no_dot}
git.url                 https://github.com/llvm-mirror/llvm.git

It built, but ymmv, I know nothing about editing portfiles and may have broken something. I imagine, for example, this is pulling from the trunk which may be unstable.

comment:13 Changed 8 years ago by gianpaolo.balsamo@…

It builds fine with the git.url. Thanks so much!

comment:14 in reply to:  12 ; Changed 8 years ago by larryv (Lawrence Velázquez)

Replying to lou@…:

There seems to be an issue with llvm.org, The checkout fails.

Did you try changing the URL to use https instead of http?

It built, but ymmv, I know nothing about editing portfiles and may have broken something. I imagine, for example, this is pulling from the trunk which may be unstable.

Right. Now you have a completely incorrect version.

comment:15 in reply to:  13 Changed 8 years ago by larryv (Lawrence Velázquez)

Replying to gianpaolo.balsamo@…:

It builds fine with the git.url. Thanks so much!

It did not “build fine”. You have a completely wrong version of LLVM now.

comment:16 in reply to:  14 Changed 8 years ago by lou@…

Replying to larryv@…:

Replying to lou@…:

There seems to be an issue with llvm.org, The checkout fails.

Did you try changing the URL to use https instead of http?

Yes. It fails.

It built, but ymmv, I know nothing about editing portfiles and may have broken something. I imagine, for example, this is pulling from the trunk which may be unstable.

Right. Now you have a completely incorrect version.

Agreed.

Last edited 8 years ago by lou@… (previous) (diff)

comment:17 Changed 8 years ago by hansimglueck@…

Yes llvm.org is offline! Is there any way to install the right version? On your mirrors the version does not exist for yosemite!!! llvm-3.5-3.5-r216817_0+assertions.darwin_14.x86_64.tbz2 packages.macports.org/llvm-3.5, lil.fr.packages.macports.org/llvm-3.5 or nue.de.packages.macports.org/macports/packages/llvm-3.5

Because you can not clone https://github.com/llvm-mirror/llvm/tree/release_35 directly....

Last edited 8 years ago by hansimglueck@… (previous) (diff)

comment:18 Changed 8 years ago by larryv (Lawrence Velázquez)

Cc: larryv@… added

Cc Me!

comment:19 Changed 8 years ago by hansimglueck@…

Ok, llvm.org is online again! It's working for now... When yosemite binaries are on your servers this should be no problem anymore! Thanks! Hans

comment:20 Changed 8 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.