Opened 7 years ago

Closed 7 years ago

Last modified 5 years ago

#45531 closed defect (invalid)

install cmake problem OS X 10.10

Reported by: ypeysson@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.2
Keywords: Cc: cssdev
Port: cmake

Description (last modified by ryandesign (Ryan Schmidt))

Hi, I try to install cmake, in a clean way from macport. I have the last Xcode 6.1 downloaded from Apple Store, and the correct sdks. It seems to compile fine, but I face a problem in the test phase that prevent the correct installation:

/bin/ps: Operation not permitted

It seems to be an already seen problem in macport, but clearly not fixed.
What can you do, or can I do ?
Thanks
Yves

:info:configure -- Forcing CTEST_TEST_CPACK=OFF on OSX < 10.4
:info:configure -- OSX_VERSION='10.10'
:info:configure -- Performing Test run_pic_test
:info:configure -- Performing Test run_pic_test - Success
:info:configure sh: /bin/ps: Operation not permitted
:info:configure CMake Error at Modules/FindGTK2.cmake:181 (file):
:info:configure   file STRINGS file
:info:configure   "/Library/Frameworks/Gtk.framework/Headers/gtk/gtk/gtkversion.h" cannot be
:info:configure   read.
:info:configure Call Stack (most recent call first):
:info:configure   Modules/FindGTK2.cmake:796 (_GTK2_GET_VERSION)
:info:configure   Tests/CMakeLists.txt:1197 (find_package)
:info:configure 
:info:configure 
:info:configure -- Configuring incomplete, errors occurred!
:info:configure See also "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_cmake/cmake/work/cmake-3.0.2/CMakeFiles/CMakeOutput.log".
:info:configure See also "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_cmake/cmake/work/cmake-3.0.2/CMakeFiles/CMakeError.log".
:info:configure ---------------------------------------------
:info:configure Error when bootstrapping CMake:
:info:configure Problem while running initial CMake
:info:configure ---------------------------------------------
:info:configure Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_cmake/cmake/work/cmake-3.0.2" && ./configure --prefix=/opt/local --mandir=/share/man --docdir=/share/doc/cmake --parallel=4 --init=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_cmake/cmake/work/cmake-3.0.2/macports.cmake --system-libs 
:info:configure Exit code: 11
:error:configure org.macports.configure for port cmake returned: configure failure: command execution failed
:debug:configure Error code: NONE
:debug:configure Backtrace: configure failure: command execution failed
    while executing
"portconfigure::configure_main org.macports.configure"
    ("eval" body line 1)
    invoked from within
"eval $procedure $targetname"
:info:configure Warning: targets not executed for cmake: org.macports.activate org.macports.configure org.macports.build org.macports.destroot org.macports.install
:notice:configure Please see the log file for port cmake for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_cmake/cmake/main.log

Change History (3)

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: css@… added
Description: modified (diff)
Milestone: MacPorts 2.3.2
Port: cmake added
Priority: HighNormal
Resolution: invalid
Status: newclosed

Please remove /Library/Frameworks/Gtk.framework and anything else you might have installed in /Library/Frameworks; it interferes with MacPorts.

comment:2 Changed 5 years ago by ironstorm@…

Hit this problem, the problem is not the existence of /Library/Frameworks/Gtk.framework, rather it is that the port looks for gtkversions.h and other headers in /Library/Frameworks/Gtk.framework/Headers/gtk/gtk/ instead of just /Library/Frameworks/Gtk.framework/Headers/gtk/.

I was able to manually work around it by symlinking Headers/gtk to Headers/gtk/gtk:

sudo ln -s /Library/Frameworks/Gtk.framework/Headers/gtk /Library/Frameworks/Gtk.framework/Headers/gtk/gtk

All together, I did the following:

sudo ln -s /Library/Frameworks/Gtk.framework/Headers/gtk /Library/Frameworks/Gtk.framework/Headers/gtk/gtk
cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_cmake/cmake/work/cmake-3.4.1"
sudo ./configure --prefix=/opt/local --docdir=share/doc/cmake --parallel=4 --init=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_cmake/cmake/work/cmake-3.4.1/macports.cmake --system-libs --no-system-jsoncpp --no-qt-gui
sudo make
sudo make install

And that seemed to get CMake installed and working.

comment:3 Changed 5 years ago by neverpanic (Clemens Lang)

No, the problem is definitely /Library/Frameworks/Gtk.framework. Standard installations of OS X don't have this, and it shouldn't be used. You may have built a version of cmake that seems to work, but MacPorts never intended that cmake links against Gtk in the packaging we provide. This might lead to problems further down the road, or it might not -- we cannot know, and we cannot support you in this.

Additionally, you manually installed files into /opt/local that were not installed by MacPorts using the sequence linked above. Because you did this, MacPorts lacks metadata about these files and additionally still assumes that cmake is not installed. If you ever try to install cmake using MacPorts or a port that depends on cmake, this installation will fail, because the files the cmake port tries to install are already there. You should never manually install software in /opt/local.

Last edited 5 years ago by neverpanic (Clemens Lang) (previous) (diff)
Note: See TracTickets for help on using tickets.