Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#45533 closed defect (duplicate)

cmake install failed

Reported by: xufucheng.2008@… Owned by: cssdev
Priority: Normal Milestone:
Component: ports Version: 2.3.2
Keywords: yosemite Cc: ryandesign (Ryan Schmidt), gthb (Gunnlaugur Thor Briem)
Port: cmake

Description (last modified by ryandesign (Ryan Schmidt))

Austen ~$sudo port upgrade outdated
--->  Computing dependencies for cmake
--->  Fetching archive for cmake
Warning: Your DNS servers incorrectly claim to know the address of nonexistent hosts. This may cause checksum mismatches for some ports. See this page for more information: <https://trac.macports.org/wiki/MisbehavingServers>
--->  Attempting to fetch cmake-3.0.2_0.darwin_14.x86_64.tbz2 from http://packages.macports.org/cmake
--->  Attempting to fetch cmake-3.0.2_0.darwin_14.x86_64.tbz2 from http://jog.id.packages.macports.org/macports/packages/cmake
--->  Attempting to fetch cmake-3.0.2_0.darwin_14.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/cmake
--->  Fetching distfiles for cmake
--->  Verifying checksums for cmake
--->  Extracting cmake
--->  Applying patches to cmake
--->  Configuring cmake
Error: org.macports.configure for port cmake returned: configure failure: command execution failed
Please see the log file for port cmake for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_cmake/cmake/main.log
Error: Unable to upgrade port: 1
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets

Attachments (1)

main.log (108.1 KB) - added by gthb (Gunnlaugur Thor Briem) 8 years ago.
main.log for my cmake configure failure

Download all attachments as: .zip

Change History (6)

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Description: modified (diff)
Keywords: yosemite added
Owner: changed from macports-tickets@… to css@…
Port: cmake added

Please attach the main.log file; without it we cannot know why this failed for you.

If you haven't upgraded to Xcode 6.1, do that; it's required for cmake on Yosemite.

Changed 8 years ago by gthb (Gunnlaugur Thor Briem)

Attachment: main.log added

main.log for my cmake configure failure

comment:2 Changed 8 years ago by gthb (Gunnlaugur Thor Briem)

(Since there wasn't any more detail from the original reporter, and my problem looks identical on the surface to the originally reported problem, I just posted my log instead.)

comment:3 Changed 8 years ago by gthb (Gunnlaugur Thor Briem)

The salient part:

:info:configure sh: /bin/ps: Operation not permitted
:info:configure CMake Error at Modules/FindGTK2.cmake:181 (file):
:info:configure   file STRINGS file
:info:configure   "/Library/Frameworks/Gtk.framework/Headers/gtk/gtk/gtkversion.h" cannot be
:info:configure   read.
:info:configure Call Stack (most recent call first):
:info:configure   Modules/FindGTK2.cmake:796 (_GTK2_GET_VERSION)
:info:configure   Tests/CMakeLists.txt:1197 (find_package)
:info:configure 
:info:configure 
:info:configure -- Configuring incomplete, errors occurred!
:info:configure See also "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_cmake/cmake/work/cmake-3.0.2/CMakeFiles/CMakeOutput.log".
:info:configure See also "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_cmake/cmake/work/cmake-3.0.2/CMakeFiles/CMakeError.log".
:info:configure ---------------------------------------------
:info:configure Error when bootstrapping CMake:
:info:configure Problem while running initial CMake
:info:configure ---------------------------------------------
:info:configure Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_cmake/cmake/work/cmake-3.0.2" && ./configure --prefix=/opt/local --mandir=/share/man --docdir=/share/doc/cmake --parallel=8 --init=/opt/local/var/macports/build/_opt_lo
:info:configure Exit code: 11
:error:configure org.macports.configure for port cmake returned: configure failure: command execution failed

That /Library/Frameworks/Gtk.framework/Headers/gtk/gtk/gtkversion.h indeed does not exist.

comment:4 Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: gunnlaugur@… added
Resolution: duplicate
Status: newclosed

xufucheng.2008 responded by email saying installing Xcode 6.1 solved the problem. That makes this a duplicate of #44581.

gunnlaugur, you are experiencing a different problem, caused by having the directory /Library/Frameworks/Gtk.framework. Please remove it and anything else that's in /Library/Frameworks; installing frameworks there can interfere with MacPorts. This is a duplicate of #44237.

comment:5 Changed 8 years ago by gthb (Gunnlaugur Thor Briem)

Indeed, the workaround in #44237 worked for me, thanks!

Note: See TracTickets for help on using tickets.