Opened 5 years ago

Closed 5 years ago

#45548 closed defect (fixed)

opam version 1.1.2 required for compiling with ocaml 4.02.1

Reported by: garrigue@… Owned by: mww@…
Priority: Normal Milestone:
Component: ports Version: 2.3.2
Keywords: Cc: anddam (Andrea D'Amore)
Port: opam

Description

ocaml has been updated to 4.02.0 (and now 4.02.1), but this breaks some dependent ports. One of them is opam, which has to be updated to 1.1.2. An extra target is also needed to build it. Here are the changed lines in the port file:

github.setup ocaml opam 1.1.2
checksums rmd160 0e9593e38aa13bc57a22028d19166bfcf67d0426 \

sha256 f7a8dee6c67cd1e7503c179a9a5b139220085b9ed7d80e6ec838a8a344cb4c71

build.target lib-ext all

Attachments (2)

Portfile (942 bytes) - added by garrigue@… 5 years ago.
Portfile.diff (878 bytes) - added by garrigue@… 5 years ago.

Download all attachments as: .zip

Change History (6)

Changed 5 years ago by garrigue@…

Attachment: Portfile added

comment:1 Changed 5 years ago by garrigue@…

Autocorrect bit me: this is of course opam, not spam!

comment:2 Changed 5 years ago by larryv (Lawrence Velázquez)

Owner: changed from macports-tickets@… to mww@…
Summary: spam version 1.1.2 required for compiling with ocaml 4.02.1opam version 1.1.2 required for compiling with ocaml 4.02.1

Thanks, but could you please attach your changes as a unified diff?

Changed 5 years ago by garrigue@…

Attachment: Portfile.diff added

comment:3 Changed 5 years ago by anddam (Andrea D'Amore)

Cc: and.damore@… added

Cc Me!

comment:4 Changed 5 years ago by anddam (Andrea D'Amore)

Resolution: fixed
Status: newclosed

Upgraded to 1.2.0 in r127366, maintainer timeout. Ticket closed.

Note: See TracTickets for help on using tickets.