Opened 7 years ago

Closed 7 years ago

#45553 closed defect (duplicate)

py-lxml @3.3.5 Bus error from lxml after importing tkinter

Reported by: radaroutthere@… Owned by: dbraband@…
Priority: Normal Milestone:
Component: ports Version: 2.3.2
Keywords: Cc: jyrkiwahlstedt, larryv (Lawrence Velázquez)
Port: py-lxml

Description

The following Python code generates 'Bus error: 10' -

import tkinter
from lxml import etree

root = etree.Element('test')
xml = etree.tostring(root)

If I reverse the order of the imports, the problem doesn't occur.

Yosemite. Reproduced under both Python 2.7 and 3.4 (adjusting the name of the tkinter module, naturally). I have tried uninstalling and re-installing lxml.

Change History (6)

comment:1 Changed 7 years ago by larryv (Lawrence Velázquez)

Cc: jwa@… added; gmail.com:dbraband removed
Owner: changed from macports-tickets@… to dbraband@…

comment:2 Changed 7 years ago by radaroutthere@…

I have filed a bug in the Python LXML bug tracker - https://bugs.launchpad.net/lxml/+bug/1384102

I have also narrowed down the problem to line 126 of /src/lxml/serializer.pxi -

tree.xmlOutputBufferFlush(c_buffer)

I can well imagine that's not the root cause, but it's the line at which the bus error is produced, and it's a place to start.

comment:3 Changed 7 years ago by ned-deily (Ned Deily)

I believe this was caused by the problem documented in #45711 where libxml2 was being built incorrectly on 10.10. That problem is now fixed. Try upgrading your ports.

comment:4 Changed 7 years ago by larryv (Lawrence Velázquez)

Cc: larryv@… added

Cc Me!

comment:5 Changed 7 years ago by radaroutthere@…

Yeah, seems to be all good now. Thanks very much!

comment:6 Changed 7 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.