Opened 6 years ago

Last modified 4 years ago

#45557 reopened defect

wxWidgets-3.0 build error

Reported by: anneknies@… Owned by: jyrkiwahlstedt
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: mojca (Mojca Miklavec)
Port: wxWidgets-3.0

Description (last modified by mojca (Mojca Miklavec))

OS X Yosemite 10.10
Xcode 6.1

sudo port install octave
error messages

  • Computing dependencies for octaveWarning: All compilers are either blacklisted or unavailable (3 times in a row)
  • Building wxWidgets-3.0
    • Error: org.macports.build for port wxWidgets-3.0 returned: command execution failed
    • Error: Failed to install wxWidgets-3.0 Please see the log file for port wxWidgets-3.0 for details: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_wxWidgets-3.0/wxWidgets-3.0/main.log
    • Error: The following dependencies were not installed: (see attachment)
    • Error: Processing of port octave failed

The actual error is:

:info:build In file included from ../src/osx/core/bitmap.cpp:39:
:info:build In file included from /System/Library/Frameworks/QuickTime.framework/Headers/QuickTime.h:39:
:info:build /System/Library/Frameworks/QuickTime.framework/Headers/MediaHandlers.h:32:10: fatal error: 'QuickTime/Movies.h' file not found
:info:build #include <QuickTime/Movies.h>
:info:build          ^
:info:build 1 error generated.

Attachments (3)

45557.txt (942 bytes) - added by anneknies@… 6 years ago.
main.log (299.8 KB) - added by anneknies@… 6 years ago.
wxWidgets-3.0 main.log file (1)
main.2.log (81.3 KB) - added by herrbischoff (Marcel Bischoff) 4 years ago.
Build error on macOS Sierra

Download all attachments as: .zip

Change History (11)

Changed 6 years ago by anneknies@…

Attachment: 45557.txt added

comment:1 Changed 6 years ago by larryv (Lawrence Velázquez)

Looks to me like wxWidgets-3.0 is the one that’s failing. Could you run the following commands and attach the main.log file that’s mentioned at failure?

% sudo port clean octave wxWidgets-3.0
% sudo port install wxWidgets-3.0

Changed 6 years ago by anneknies@…

Attachment: main.log added

wxWidgets-3.0 main.log file (1)

comment:2 in reply to:  1 Changed 6 years ago by anneknies@…

Replying to larryv@…: The requested file has been attached.

comment:3 Changed 5 years ago by mf2k (Frank Schima)

Cc: mojca@… added
Owner: changed from macports-tickets@… to jwa@…
Port: wxWidgets-3.0 added; octave removed
Summary: octave @3.8.2_1 All compilers are either blacklisted or unavailablewxWidgets-3.0 build error

Is this still a problem?

comment:4 Changed 5 years ago by mojca (Mojca Miklavec)

Description: modified (diff)
Version: 2.3.2

This looks like a broken QuickTime library. I wouldn't bet on it, but this looks like unreproducible problem to me (with nobody else complaining about the same problem).

comment:5 Changed 4 years ago by herrbischoff (Marcel Bischoff)

The same issue appears on mac OS 10.12 with Xcode 8 for me. Please see attached build log.

Changed 4 years ago by herrbischoff (Marcel Bischoff)

Attachment: main.2.log added

Build error on macOS Sierra

comment:6 Changed 4 years ago by mojca (Mojca Miklavec)

Resolution: worksforme
Status: newclosed

Marcel, your issue seems to be #52069.

comment:7 Changed 4 years ago by platipodium (Carsten Lemmen)

Resolution: worksforme
Status: closedreopened

Ii seem to have the same problem with qtplay on sierra

port clean qtplay
port build qtplay

MACOSX_DEPLOYMENT_TARGET='10.12'

:debug:build cd /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_audio_qtplay/qtplay/work/qtplay1.3.1 && /usr/bin/clang -o qtplay -framework Carbon -framework QuickTime -arch i386 qtplay.c
:info:build qtplay.c:139:9: fatal error: 'QuickTime/Movies.h' file not found
:info:build #import <QuickTime/Movies.h>

comment:8 Changed 4 years ago by mojca (Mojca Miklavec)

Carsten, please open a new ticket as this is unrelated to wxWidgets (you may post a link here though).

One should fix qtplay. The port has no maintainer, it would be best if you could (also) file a ticket upstream.

Note: See TracTickets for help on using tickets.