Opened 5 years ago

Closed 5 years ago

#45559 closed defect (fixed)

lablgtk2 @2.18.0_0 Configure Error - Build Failure

Reported by: spook@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.2
Keywords: Cc: hippallium-macports@…, someuser12, majoc-at-astro (majoc-at-astro)
Port: lablgtk2

Description

port install lablgtk2 fails with:

--->  Configuring lablgtk2
Error: Failed to configure lablgtk2, consult /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_lablgtk2/lablgtk2/work/lablgtk-2.18.0/config.log
Error: org.macports.configure for port lablgtk2 returned: configure failure: command execution failed
Please see the log file for port lablgtk2 for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_lablgtk2/lablgtk2/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port lablgtk2 failed

The problem from the config log seems to be:

configure:2592: checking for camlp4o
configure:2620: result: no
configure:2629: error: Cannot find camlp4o.

But I have camlp5 installed.

Attachments (3)

main.log (152.3 KB) - added by spook@… 5 years ago.
main.log
config.log (8.1 KB) - added by spook@… 5 years ago.
config.log
Portfile.diff (1.2 KB) - added by someuser12 5 years ago.
Update proposal to the portfile of lablgtk2

Download all attachments as: .zip

Change History (11)

Changed 5 years ago by spook@…

Attachment: main.log added

main.log

Changed 5 years ago by spook@…

Attachment: config.log added

config.log

comment:1 Changed 5 years ago by hippallium-macports@…

Cc: hippallium-macports@… added

Cc Me!

comment:2 Changed 5 years ago by someuser12

After installing the ocaml-camlp4 port, which apparently does not conflict with camlp5, I was able to reinstall lablgtk2 from source (port -s install lablgtk2).

Which I needed since the precompiled port of lablgtk2 2.18.0 (at least for Mac OS 10.8) has a file which got broken by the recent upgrade to ocaml +4.02.1_0:

Error: /opt/local/lib/ocaml/site-lib/lablgtk2/pango.cmi
is not a compiled interface for this version of OCaml.
It seems to be for an older version of OCaml.

Therefore, we might want to add ocaml-camlp4 to the build dependencies of lablgtk2, possibly after checking that the newest version of lablgtk2 (2.18.2) still has this issue.

HTH!

Last edited 5 years ago by someuser12 (previous) (diff)

comment:3 Changed 5 years ago by someuser12

Cc: macosx12345@… added

Cc Me!

comment:4 in reply to:  description ; Changed 5 years ago by someuser12

Same issue with lablgtk2 2.18.2. I attached a proposal for a new portfile.

Changed 5 years ago by someuser12

Attachment: Portfile.diff added

Update proposal to the portfile of lablgtk2

comment:5 in reply to:  4 Changed 5 years ago by someuser12

Replying to macosx12345@…:

Same issue with lablgtk2 2.18.2. I attached a proposal for a new portfile.

lablgtk2 2.18.3 (just released) fixes crashes in e.g. unison when compiled with ocaml 4.02 rather than ocaml <= 4.01.

comment:6 Changed 5 years ago by majoc-at-astro (majoc-at-astro)

Cc: majoc@… added

Cc Me!

comment:7 Changed 5 years ago by ryandesign (Ryan Schmidt)

With this patch, lablgtk2 depends on both ocaml-camlp4 and ocaml-findlib which conflict with one another and thus cannot be active at the same time.

comment:8 Changed 5 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.