Opened 3 years ago

Closed 3 years ago

#45603 closed defect (duplicate)

gcc46 does not build

Reported by: pf289@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.2
Keywords: yosemite Cc: ryandesign (Ryan Schmidt)
Port: gcc46

Description (last modified by ryandesign (Ryan Schmidt))

I've recently upgraded my mac os X to Yosemite, similarly with Xcode and Macports. When I try to upgrade gcc46 I get the following error message:

--->  Building gcc46
Error: org.macports.build for port gcc46 returned: command execution failed
Please see the log file for port gcc46 for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_gcc46/gcc46/main.log
Error: Problem while installing gcc46

Attachments (1)

main.log.zip (480.1 KB) - added by pf289@… 3 years ago.
main.log file

Download all attachments as: .zip

Change History (4)

comment:1 follow-up: Changed 3 years ago by ryandesign (Ryan Schmidt)

  • Description modified (diff)
  • Keywords gcc removed

Please attach the main.log file.

Changed 3 years ago by pf289@…

main.log file

comment:2 in reply to: ↑ 1 Changed 3 years ago by pf289@…

Replying to ryandesign@…:

Please attach the main.log file.

Just added the main.log file

comment:3 Changed 3 years ago by ryandesign (Ryan Schmidt)

  • Cc ryandesign@… added
  • Keywords yosemite added
  • Resolution set to duplicate
  • Status changed from new to closed

The log says:

error: unknown value '10.10' of -mmacosx-version-min

This is a duplicate of #43978. Until we fix gcc47 and earlier, please use gcc48 and later on Yosemite.

Note: See TracTickets for help on using tickets.