Opened 3 years ago

Last modified 12 months ago

#45612 assigned defect

Failed to Install SoXt on Yosemite

Reported by: matthewl.lund@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.2
Keywords: Cc: mkae (Marko Käning), jsnuverink@…
Port: SoXt

Description (last modified by ryandesign (Ryan Schmidt))

SoXt failed to install on a brand new install of MacPorts on Yosemite. All other ports install fine, from the log file I get the following error message with "symbol(s) not found for architecture x86_6". I've tried cleaning the port and reinstalling with same error. Attached is the log file.

:info:build Undefined symbols for architecture x86_64:
:info:build   "_glXChooseVisual", referenced from:
:info:build       SoXtGLWidget::buildWidget(_WidgetRec*) in libSoXt.2.0.0.dylib-master.o
:info:build       Initialize(_SoXtGLAreaRec*, _SoXtGLAreaRec*, Arg*, unsigned int*) in libSoXt.2.0.0.dylib-master.o
:info:build   "_glXCreateContext", referenced from:
:info:build       SoXtGLWidgetP::initNormalContext() in libSoXt.2.0.0.dylib-master.o
:info:build   "_glXGetCurrentContext", referenced from:
:info:build       SoXtGLWidgetP::isDirectRendering() in libSoXt.2.0.0.dylib-master.o
:info:build   "_glXIsDirect", referenced from:
:info:build       SoXtGLWidgetP::isDirectRendering() in libSoXt.2.0.0.dylib-master.o
:info:build   "_glXMakeCurrent", referenced from:
:info:build       SoXtGLWidget::glLockNormal() in libSoXt.2.0.0.dylib-master.o
:info:build       _SoXtGLAreaMakeCurrent in libSoXt.2.0.0.dylib-master.o
:info:build   "_glXSwapBuffers", referenced from:
:info:build       SoXtGLWidget::glSwapBuffers() in libSoXt.2.0.0.dylib-master.o
:info:build       _SoXtGLAreaSwapBuffers in libSoXt.2.0.0.dylib-master.o
:info:build ld: symbol(s) not found for architecture x86_64
:info:build clang: error: linker command failed with exit code 1 (use -v to see invocation)
:info:build make[8]: *** [libSoXt.la] Error 1

Attachments (1)

soxt.log (295.3 KB) - added by matthewl.lund@… 3 years ago.

Download all attachments as: .zip

Change History (7)

Changed 3 years ago by matthewl.lund@…

comment:1 Changed 3 years ago by ryandesign (Ryan Schmidt)

  • Description modified (diff)
  • Owner changed from macports-tickets@… to css@…
  • Port SoXt added

comment:2 Changed 2 years ago by mkae (Marko Käning)

  • Cc mk@… added

Cc Me!

comment:3 Changed 2 years ago by cssdev

  • Status changed from new to assigned

That looks like a simple linker error, however when dealing with source this old it may never be so simple. I'll take a look.

comment:4 Changed 2 years ago by cssdev

I wonder if this might have something to do with the X11 stubs that Apple implemented. I ran into some issues getting the SGI inventor port working on El Capitan, and perhaps this port is also pulling in the stubs rather than the Macports libraries. This would explain the behavior, as the stubs would get found and linked but lack the required symbols. I'll troubleshoot this one next weekend.

comment:5 Changed 21 months ago by jsnuverink@…

  • Cc jsnuverink@… added

Cc Me!

comment:6 Changed 12 months ago by kurthindenburg (Kurt Hindenburg)

  • Owner changed from css@… to macports-tickets@…
Note: See TracTickets for help on using tickets.