Opened 5 years ago

Closed 5 years ago

#45614 closed defect (fixed)

eigen3 @3.2.2 +gcc49 +blas Build Error

Reported by: William.Capehart@… Owned by: eborisch (Eric A. Borisch)
Priority: Normal Milestone:
Component: ports Version: 2.3.2
Keywords: Cc:
Port: eigen3

Description

For Yosemite's macports build I am getting the following error (inhibiting me from installing gnudatalanguage and a few other things...)

:debug:destroot Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_eigen3/eigen3/work/3.2.2" && /usr/bin/make -w install DESTDIR=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_eigen3/eigen3/work/destroot'
:debug:destroot Executing command line:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_eigen3/eigen3/work/3.2.2" && /usr/bin/make -w install DESTDIR=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_eigen3/eigen3/work/destroot 
:info:destroot make: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_eigen3/eigen3/work/3.2.2'
:info:destroot /opt/local/bin/cmake -H/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_eigen3/eigen3/work/eigen_src -B/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_eigen3/eigen3/work/3.2.2 --check-build-system CMakeFiles/Makefile.cmake 0
:info:destroot /opt/local/bin/cmake -E cmake_progress_start /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_eigen3/eigen3/work/3.2.2/CMakeFiles /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_eigen3/eigen3/work/3.2.2/CMakeFiles/progress.marks
:info:destroot /Applications/Xcode.app/Contents/Developer/usr/bin/make -f CMakeFiles/Makefile2 all
:info:destroot make[1]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_eigen3/eigen3/work/3.2.2'
:info:destroot make[1]: Nothing to be done for `all'.
:info:destroot make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_eigen3/eigen3/work/3.2.2'
:info:destroot /opt/local/bin/cmake -E cmake_progress_start /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_eigen3/eigen3/work/3.2.2/CMakeFiles 0
:info:destroot /Applications/Xcode.app/Contents/Developer/usr/bin/make -f CMakeFiles/Makefile2 preinstall
:info:destroot make[1]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_eigen3/eigen3/work/3.2.2'
:info:destroot make[1]: Nothing to be done for `preinstall'.
:info:destroot make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_eigen3/eigen3/work/3.2.2'
:info:destroot Install the project...
:info:destroot /opt/local/bin/cmake -P cmake_install.cmake
:info:destroot -- Install configuration: "Release"
:info:destroot -- Installing: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_eigen3/eigen3/work/destroot/opt/local/include/eigen3/signature_of_eigen3_matrix_library
:info:destroot CMake Error at cmake_install.cmake:51 (file):
:info:destroot   file called with network path DESTINATION.  This does not make sense when
:info:destroot   using DESTDIR.  Specify local absolute path or remove DESTDIR environment
:info:destroot   variable.
:info:destroot 
:info:destroot   DESTINATION=
:info:destroot 
:info:destroot   //Library/Frameworks/pkgconfig
:info:destroot 
:info:destroot 
:info:destroot make: *** [install] Error 1
:info:destroot make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_eigen3/eigen3/work/3.2.2'
:info:destroot Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_eigen3/eigen3/work/3.2.2" && /usr/bin/make -w install DESTDIR=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_eigen3/eigen3/work/destroot 
:info:destroot Exit code: 2
:error:destroot org.macports.destroot for port eigen3 returned: command execution failed
:debug:destroot Error code: CHILDSTATUS 47402 2
:debug:destroot Backtrace: command execution failed
    while executing
"system -nice 0 $fullcmdstring"
    ("eval" body line 1)
    invoked from within
"eval system $notty $nice \$fullcmdstring"
    invoked from within
"command_exec destroot"
    (procedure "portdestroot::destroot_main" line 2)
    invoked from within
"portdestroot::destroot_main org.macports.destroot"
    ("eval" body line 1)
    invoked from within
"eval $procedure $targetname"
:info:destroot Warning: targets not executed for eigen3: org.macports.activate org.macports.destroot org.macports.install
:notice:destroot Please see the log file for port eigen3 for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_math_eigen3/eigen3/main.log

Log is attached

Thanks Much Bill Capehart

Attachments (3)

eigen3.macports.log (158.7 KB) - added by William.Capehart@… 5 years ago.
eigen3_gcc48_blas_log_2014-10-30.txt (158.7 KB) - added by William.Capehart@… 5 years ago.
eigen+blas+gcc log for 2014-10-30
eigen3_log_2014-10-30.txt (53.9 KB) - added by William.Capehart@… 5 years ago.
eigen (no extras) log for 2014-10-30

Download all attachments as: .zip

Change History (11)

Changed 5 years ago by William.Capehart@…

Attachment: eigen3.macports.log added

comment:1 Changed 5 years ago by larryv (Lawrence Velázquez)

Cc: eborisch@… openmaintainer@… removed
Owner: changed from macports-tickets@… to eborisch@…

comment:2 Changed 5 years ago by eborisch (Eric A. Borisch)

Resolution: worksforme
Status: newclosed

Could not reproduce. Was likely fixed (CMake issue) by r127220. Try updating and installing again.

comment:3 Changed 5 years ago by William.Capehart@…

cmake was indeed updated this weekend. However, after a clean --all but still no luck. This does not install and the error is the same. This isn't closed. Same happens when I install without the +blas +gcc49

comment:4 Changed 5 years ago by eborisch (Eric A. Borisch)

Resolution: worksforme
Status: closedreopened

Hrmm. Looking closer at the full log, there may be a missing dependency. Can you install pkgconfig and then try? If that fixes it, I'll add it as a dependency.

Changed 5 years ago by William.Capehart@…

eigen+blas+gcc log for 2014-10-30

Changed 5 years ago by William.Capehart@…

Attachment: eigen3_log_2014-10-30.txt added

eigen (no extras) log for 2014-10-30

comment:5 Changed 5 years ago by William.Capehart@…

OK PKGCONFIG has been installed (was not earlier...

Clean-all Force Installed cmake again.

Clean-all installed eigen3 with and without +blas & +gcc49 and am still hitting getting a similar error.

Logs are attached (that should read gcc49 not 48 in the name of that one file).

Bill

comment:6 Changed 5 years ago by eborisch (Eric A. Borisch)

Try cleaning eigen3 and then running this:

sudo port install eigen3 configure.env=PKG_CONFIG_LIBDIR=/opt/local/lib/pkgconfig

comment:7 Changed 5 years ago by William.Capehart@…

This still did not work UNTIL I renamed the empty directory Library/Frameworks/pkgconfig to Library/Frameworks/pkgconfig.arch At that point after a clean and install with your config.env option it worked. Thanks Much!

comment:8 Changed 5 years ago by eborisch (Eric A. Borisch)

Resolution: fixed
Status: reopenedclosed

Added dependency and environment tweak in r128150.

Note: See TracTickets for help on using tickets.