Opened 6 years ago

Closed 2 years ago

Last modified 2 years ago

#45634 closed defect (fixed)

InsightToolkit @3.16.0_3: needs variant for newer Python

Reported by: sofigantunes@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.2
Keywords: Cc: petrrr
Port: InsightToolkit

Description (last modified by larryv (Lawrence Velázquez))

--->  Computing dependencies for InsightToolkit
--->  Dependencies to be installed: python25
--->  Fetching distfiles for python25
Error: python25 is not supported on Yosemite or later.
Error: org.macports.fetch for port python25 returned: unsupported platform
Error: Failed to install python25

Change History (7)

comment:1 Changed 6 years ago by larryv (Lawrence Velázquez)

Description: modified (diff)
Port: InsightToolkit added
Priority: HighNormal
Summary: InsightToolkit python25 not supported on YosemiteInsightToolkit @3.16.0_3: needs variant for newer Python

python25 currently doesn’t build on Yosemite, and as I’ll be retiring it at the end of the year anyway, we won’t be fixing it.

InsightToolkit ought to be updated to use either Python 2.7 or 3.4, though. Unfortunately, the portfile is somewhat complex and involves a lot of CMake, which I’m not familiar with. Perhaps you could ask for help with it on macports-users or macports-dev.

Last edited 6 years ago by larryv (Lawrence Velázquez) (previous) (diff)

comment:2 Changed 6 years ago by petrrr

The version 3.16 (September 15 2009), so there is some risk for incompatibility. So maybe we want to update as well.

  • The last version of the 3.x series is Release 3.20 (July 12 2010);
  • Current release is 4.6.1 from September 2014.

See here for more details.

Last edited 6 years ago by petrrr (previous) (diff)

comment:3 Changed 6 years ago by petrrr

Update was already requested in ticket #37894.

comment:4 Changed 6 years ago by petrrr

Cc: petr@… added

Cc Me!

comment:5 Changed 5 years ago by mioose@…

Hello, I have the same problem on 10.11 El Capitan. I have tried to reinstall as they advice here: http://stackoverflow.com/questions/27873045/port-upgrade-outdated-fails-in-yosemite But I obtain the same error : " Error: python25 is not supported on Yosemite or later. Error: org.macports.fetch for port python25 returned: unsupported platform Error: Failed to install python25 "

Others dependencies have to be installed: "Error: The following dependencies were not installed: python25 tk Xft2 tcl xorg-libXScrnSaver xorg-scrnsaverproto" I really do not know what to do, I have to work on ITK next week… Can someone Help me, please?

comment:6 Changed 2 years ago by yan12125 (Chih-Hsuan Yen)

Resolution: fixed
Status: newclosed

In 1b59ebeba1383f1288adf62161e256119283fec1/macports-ports (master):

InsightToolkit{,312,314}: removed in favor of InsightToolkit-devel

The last ITK 3.x release 3.20 is out in 2010, and 4.x have been there
for almost 8 years. I see no reason to keep 3.x around.

Closes: #23772
Closes: #26373
Closes: #33857
Closes: #37894
Closes: #42973
Closes: #45634
Closes: #45670
Ref: #47691

comment:7 Changed 2 years ago by yan12125 (Chih-Hsuan Yen)

InsightToolkit (3.16.0) has been dropped in favor of InsightToolkit-devel (4.8.2). The latter does not include Python bindings. Feel free to open new issues if you need to use ITK with Python.

Note: See TracTickets for help on using tickets.