Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#45677 closed defect (duplicate)

Warning: All compilers are either blacklisted or unavailable; defaulting to first fallback option

Reported by: dbl001 (dbl) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.2
Keywords: Cc:
Port: mysql5

Description (last modified by ryandesign (Ryan Schmidt))

Macport 2.3.3
OS X: 10.9.5 Yosemite

sudo port selfupdate
Password:
--->  Updating MacPorts base sources using rsync
MacPorts base version 2.3.2 installed,
MacPorts base version 2.3.2 downloaded.
--->  Updating the ports tree
--->  Updating the ports tree
--->  MacPorts base is already the latest version

The ports tree has been updated. To upgrade your installed ports, you should run
  port upgrade outdated

sudo port upgrade outdated
Password:
--->  Computing dependencies for gtk3
--->  Fetching archive for gtk3

...

--->  Attempting to fetch mysql5-5.1.72_0.darwin_14.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/mysql5
--->  Attempting to fetch mysql5-5.1.72_0.darwin_14.x86_64.tbz2 from http://jog.id.packages.macports.org/macports/packages/mysql5
--->  Computing dependencies for mysql5
--->  Fetching distfiles for mysql5
--->  Attempting to fetch mysql-5.1.72.tar.gz from http://mirror.leaseweb.com/mysql/Downloads/MySQL-5.1
--->  Verifying checksums for mysql5                                            
--->  Extracting mysql5
--->  Applying patches to mysql5
--->  Configuring mysql5
Warning: All compilers are either blacklisted or unavailable; defaulting to first fallback option
Warning: All compilers are either blacklisted or unavailable; defaulting to first fallback option
...

Attachments (1)

main.log (14.6 KB) - added by dbl001 (dbl) 8 years ago.

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by dbl001 (dbl)

Attachment: main.log added

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Port: mysql5 added
Resolution: duplicate
Status: newclosed

Duplicate of #45455. Please use a newer version of mysql5.

comment:2 Changed 8 years ago by peter.h.m.brooks@…

I've had this problem ever since installing Yosemite. It's really annoying. I've tried all sorts of things to fix it, including re-installing mac ports from scratch, checking all security settings (in case it was part of the application protection code), re-installing Xcode and more.

Any suggestions, even for things to try would be most gratefully received.

comment:3 Changed 8 years ago by dbl001 (dbl)

Try this:

$ sudo port install port_cutleaves $ sudo port_cutleaves $ sudo port upgrade outdated $ sudo port clean --all installed

$ sudo port uninstall mysql5-server $ sudo port uninstall mysql5

$ sudo port install mysql56 $ port list select mysql56 mysql56 @5.6.21 databases/mysql56

comment:4 in reply to:  2 Changed 8 years ago by larryv (Lawrence Velázquez)

Replying to peter.h.m.brooks@…:

I've had this problem ever since installing Yosemite. It's really annoying. I've tried all sorts of things to fix it

There is nothing to fix. Xcode 6 simply cannot satisfy the compiler constraints dictated by the mysql5 port.

As Ryan said, you should install another MySQL/MariaDB/Percona port, as mysql5 is deprecated.

Note: See TracTickets for help on using tickets.