Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#45776 closed defect (duplicate)

transfig: fails on build on yosemite

Reported by: skymoo (Adam Mercer) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.2
Keywords: yosemite Cc: ryandesign (Ryan Schmidt), mp@…
Port: transfig

Description

build log attached

Attachments (1)

main.log (4.2 KB) - added by skymoo (Adam Mercer) 6 years ago.

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by skymoo (Adam Mercer)

Attachment: main.log added

comment:1 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Resolution: duplicate
Status: newclosed

This was fixed some time ago. Please run:

sudo port clean transfig
sudo port selfupdate

Then try again.

comment:2 in reply to:  1 Changed 6 years ago by mp@…

Getting the same error on Mavericks, even after clean and selfupdate.

Solved it for now with this bypass surgery of the configure stage:

sudo port clean transfig
sudo port patch transfig
cd $(port work transfig)/transfig*
sudo xmkmf -a
sudo sh -c 'echo "target: org.macports.configure" >>../.macports.transfig.state'
cd -
sudo port install transfig

comment:3 Changed 6 years ago by mp@…

Cc: mp@… added

Cc Me!

Note: See TracTickets for help on using tickets.