Opened 16 years ago

Closed 15 years ago

Last modified 10 years ago

#4598 closed defect (fixed)

libxml2: libxml2-2.6.19: No such file or directory

Reported by: sfque@… Owned by: michaelm@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: markd@…
Port: libxml2

Description (last modified by ryandesign (Ryan Schmidt))

I had tried using Port Authority, and it does not show any error. However, running the following from command prompt;

$sudo /opt/local/bin/port -d install dia

gives the following;

$ sudo /opt/local/bin/port -d install dia
DEBUG: Found port in
file:///opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/gnome/dia
DEBUG: Changing to port directory:
/opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/gnome/dia
DEBUG: Requested variant powerpc is not provided by port dia.
DEBUG: Requested variant darwin is not provided by port dia.
DEBUG: Requested variant macosx is not provided by port dia.
DEBUG: Found port in
file:///opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/x11/gtk2
DEBUG: Changing to port directory:
/opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/x11/gtk2
DEBUG: Searching for dependency: gtk2
DEBUG: Found Dependency: receipt exists for gtk2
DEBUG: Found port in
file:///opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/textproc/libxml2
DEBUG: Changing to port directory:
/opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/textproc/libxml2
DEBUG: Searching for dependency: libxml2
DEBUG: Didn't find receipt, going to depspec regex for: libxml2
DEBUG: Found port in
file:///opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/textproc/libxslt
DEBUG: Changing to port directory:
/opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/textproc/libxslt
DEBUG: Searching for dependency: libxslt
DEBUG: Didn't find receipt, going to depspec regex for: libxslt
DEBUG: Found port in
file:///opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/perl/p5-xml-parser
DEBUG: Changing to port directory:
/opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/perl/p5-xml-parser
DEBUG: Searching for dependency: p5-xml-parser
DEBUG: Didn't find receipt, going to depspec regex for: p5-xml-parser
DEBUG: Found port in
file:///opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/textproc/libiconv
DEBUG: Changing to port directory:
/opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/textproc/libiconv
DEBUG: Searching for dependency: libiconv
DEBUG: Found Dependency: receipt exists for libiconv
DEBUG: Found port in
file:///opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/textproc/libxml2
DEBUG: Searching for dependency: libxml2
DEBUG: Didn't find receipt, going to depspec regex for: libxml2
DEBUG: Found port in
file:///opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/lang/perl5.8
DEBUG: Changing to port directory:
/opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/lang/perl5.8
DEBUG: Searching for dependency: perl5.8
DEBUG: Didn't find receipt, going to depspec regex for: perl5.8
DEBUG: Found port in
file:///opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/textproc/expat
DEBUG: Changing to port directory:
/opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/textproc/expat
DEBUG: Searching for dependency: expat
DEBUG: Found Dependency: receipt exists for expat
DEBUG: Requested variant powerpc is not provided by port libxml2.
DEBUG: Requested variant darwin is not provided by port libxml2.
DEBUG: Requested variant macosx is not provided by port libxml2.
DEBUG: Skipping completed com.apple.main (libxml2)
DEBUG: Skipping completed com.apple.unarchive (libxml2)
DEBUG: Skipping completed com.apple.fetch (libxml2)
DEBUG: Skipping completed com.apple.checksum (libxml2)
DEBUG: setting option extract.cmd to /usr/bin/bzip2
DEBUG: Skipping completed com.apple.extract (libxml2)
DEBUG: Skipping completed com.apple.patch (libxml2)
--->  Configuring libxml2
DEBUG: Executing com.apple.configure (libxml2)
DEBUG: Assembled command: 'cd
"/opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_textproc_libxml2/work/libxml2-2.6.19"
&& BASE_DIR=/opt/local/share/doc ./configure --prefix=/opt/local
--mandir=/opt/local/share/man --with-iconv=/opt/local --enable-static=no'
sh: line 1: cd:
/opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_textproc_libxml2/work/libxml2-2.6.19:
No such file or directory
Error: Target com.apple.configure returned: configure failure: shell command "cd
"/opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_textproc_libxml2/work/libxml2-2.6.19"
&& BASE_DIR=/opt/local/share/doc ./configure --prefix=/opt/local
--mandir=/opt/local/share/man --with-iconv=/opt/local --enable-static=no"
returned error 1
Command output: sh: line 1: cd:
/opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_textproc_libxml2/work/libxml2-2.6.19:
No such file or directory

Warning: the following items did not execute (for libxml2): com.apple.activate
com.apple.configure com.apple.build com.apple.destroot com.apple.archive
com.apple.install
Error: The following dependencies failed to build: libxml2 libxslt p5-xml-parser
perl5.8

This is what is under /opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_textproc_libxml2/work

$ ls -al
/opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_textproc_libxml2/work
total 8
drwxr-xr-x     4 root  admin   136 Aug 19 16:27 .
drwxr-xr-x     3 root  admin   102 Aug 19 16:24 ..
-rw-r--r--     1 root  admin   152 Aug 19 16:27 .darwinports.libxml2.state
drwxrwxrwx   123 root  admin  4182 Aug 19 16:27 libxml2-2.6.16

I have updated DarwinPorts through Port Authority, but no change in the above.

TIA
Faruque

Change History (9)

comment:1 Changed 16 years ago by olegb@…

* Bug 4597 has been marked as a duplicate of this bug. *

comment:2 Changed 16 years ago by sfque@…

I have followed the instructions left on 4597 in any case; i.e. I did

port -d clean --all dia and attach the output of: port -d destroot dia

and this is the output;

$ sudo /opt/local/bin/port -d destroot dia DEBUG: Found port in file:///opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/gnome/dia DEBUG: Changing to port directory: /opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/gnome/dia DEBUG: Requested variant powerpc is not provided by port dia. DEBUG: Requested variant darwin is not provided by port dia. DEBUG: Requested variant macosx is not provided by port dia. DEBUG: Found port in file:///opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/x11/gtk2 DEBUG: Changing to port directory: /opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/x11/gtk2 DEBUG: Searching for dependency: gtk2 DEBUG: Found Dependency: receipt exists for gtk2 DEBUG: Found port in file:///opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/textproc/libxml2 DEBUG: Changing to port directory: /opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/textproc/libxml2 DEBUG: Searching for dependency: libxml2 DEBUG: Didn't find receipt, going to depspec regex for: libxml2 DEBUG: Found port in file:///opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/textproc/libxslt DEBUG: Changing to port directory: /opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/textproc/libxslt DEBUG: Searching for dependency: libxslt DEBUG: Didn't find receipt, going to depspec regex for: libxslt DEBUG: Found port in file:///opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/perl/p5-xml-parser DEBUG: Changing to port directory: /opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/perl/p5-xml-parser DEBUG: Searching for dependency: p5-xml-parser DEBUG: Didn't find receipt, going to depspec regex for: p5-xml-parser DEBUG: Found port in file:///opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/textproc/libiconv DEBUG: Changing to port directory: /opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/textproc/libiconv DEBUG: Searching for dependency: libiconv DEBUG: Found Dependency: receipt exists for libiconv DEBUG: Found port in file:///opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/textproc/libxml2 DEBUG: Searching for dependency: libxml2 DEBUG: Didn't find receipt, going to depspec regex for: libxml2 DEBUG: Found port in file:///opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/lang/perl5.8 DEBUG: Changing to port directory: /opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/lang/perl5.8 DEBUG: Searching for dependency: perl5.8 DEBUG: Didn't find receipt, going to depspec regex for: perl5.8 DEBUG: Found port in file:///opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/textproc/expat DEBUG: Changing to port directory: /opt/local/var/db/dports/sources/rsync.rsync.opendarwin.org_dpupdate_dports/textproc/expat DEBUG: Searching for dependency: expat DEBUG: Found Dependency: receipt exists for expat DEBUG: Requested variant powerpc is not provided by port libxml2. DEBUG: Requested variant darwin is not provided by port libxml2. DEBUG: Requested variant macosx is not provided by port libxml2. DEBUG: Skipping completed com.apple.main (libxml2) DEBUG: Skipping completed com.apple.unarchive (libxml2) DEBUG: Skipping completed com.apple.fetch (libxml2) DEBUG: Skipping completed com.apple.checksum (libxml2) DEBUG: setting option extract.cmd to /usr/bin/bzip2 DEBUG: Skipping completed com.apple.extract (libxml2) DEBUG: Skipping completed com.apple.patch (libxml2) ---> Configuring libxml2 DEBUG: Executing com.apple.configure (libxml2) DEBUG: Assembled command: 'cd "/opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_textproc_libxml2/work/libxml2-2.6.19" && BASE_DIR=/opt/local/share/doc ./configure --prefix=/opt/local --mandir=/opt/local/share/man --with-iconv=/opt/local --enable-static=no' sh: line 1: cd: /opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_textproc_libxml2/work/libxml2-2.6.19: No such file or directory Error: Target com.apple.configure returned: configure failure: shell command "cd "/opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_textproc_libxml2/work/libxml2-2.6.19" && BASE_DIR=/opt/local/share/doc ./configure --prefix=/opt/local --mandir=/opt/local/share/man --with-iconv=/opt/local --enable-static=no" returned error 1 Command output: sh: line 1: cd: /opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_textproc_libxml2/work/libxml2-2.6.19: No such file or directory

Warning: the following items did not execute (for libxml2): com.apple.activate com.apple.configure com.apple.build com.apple.destroot com.apple.archive com.apple.install Error: The following dependencies failed to build: libxml2 libxslt p5-xml-parser perl5.8

TIA Faruque

comment:3 Changed 16 years ago by mww@…

Owner: changed from darwinports-bugs@… to olegb@…

comment:4 Changed 16 years ago by olegb@…

Owner: changed from olegb@… to michaelm@…

This is a problem with libxml2 breaking, not a dia problem. Assigning to libxml2 maintainer.

comment:5 Changed 15 years ago by sfque@…

Hello Michael

I wonder if you got a chance to look at this?

tia Faruque

comment:6 Changed 15 years ago by mww@…

Summary: Dia 0.94 does not installBUG: Dia 0.94 does not install

comment:7 Changed 15 years ago by markd@…

Cc: markd@… added

(In reply to comment #3)

This is a problem with libxml2 breaking, not a dia problem. Assigning to libxml2 maintainer.

libxml2 has since been updated. I think this bug should be closed.

comment:8 Changed 15 years ago by blb@…

Resolution: fixed
Status: newclosed

Resolving per markd@'s comment. If it still occurs with 2.6.22, reopen.

comment:9 Changed 10 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Port: libxml2 added
Summary: BUG: Dia 0.94 does not installlibxml2: libxml2-2.6.19: No such file or directory

This was probably caused by #29223.

Note: See TracTickets for help on using tickets.