Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#46020 closed defect (duplicate)

libgcc 4.9.2 build fails (10.5.8 intel)

Reported by: potmj Owned by: larryv (Lawrence Velázquez)
Priority: Normal Milestone:
Component: ports Version: 2.3.3
Keywords: leopard Cc: mww@…, dershow, macports.mails.skeeve@…, keloin@…
Port: libgcc gcc49

Description (last modified by ryandesign (Ryan Schmidt))

sudo port clean libgcc
sudo port upgrade libgcc
command execution failed
ld returned 1 exit status
:info:build ld: illegal text-relocoation (direct reference) to (global,weak) hash_table<loc_list_hasher, xcallocator>::find_slot_with_hash(dw_loc_list_struct const*, unsigned int, insert_option) in libbackend.a(dwarf2out.o) from anon in libbackend.a(dwarf2out.o) for architecture i386

Looks like it is happening in 2 jobs.

Attachments (2)

main.log.gz (139.1 KB) - added by potmj 5 years ago.
main_1job.log.gz (133.8 KB) - added by potmj 5 years ago.
build.jobs=1

Download all attachments as: .zip

Change History (13)

Changed 5 years ago by potmj

Attachment: main.log.gz added

comment:1 Changed 5 years ago by ryandesign (Ryan Schmidt)

Cc: mww@… openmaintainer@… removed
Description: modified (diff)
Owner: changed from macports-tickets@… to mww@…

comment:2 Changed 5 years ago by larryv (Lawrence Velázquez)

Cc: larryv@… added

Cc Me!

comment:3 Changed 5 years ago by larryv (Lawrence Velázquez)

Can you post a single-threaded log?

% sudo port clean libgcc
% sudo port upgrade libgcc build.jobs=1

Changed 5 years ago by potmj

Attachment: main_1job.log.gz added

build.jobs=1

comment:4 Changed 5 years ago by dershow

I am seeing an error upgrading from libgcc from 4.9.2_0 to 4.9.2_1 I am on 10.9.5. I also see this ticket #46040 that might be related, but it is not clear if it is an identical problem or not.

Last edited 5 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:5 Changed 5 years ago by dershow

Cc: dersh@… added

Cc Me!

comment:6 Changed 5 years ago by larryv (Lawrence Velázquez)

Cc: mww@… macports.mails.skeeve@… added; larryv@… removed
Keywords: leopard added
Owner: changed from mww@… to larryv@…
Port: gcc49 added
Status: newassigned

Has duplicate #46068.

Have any of you been able to build GCC 4.9.2 in the past?

comment:7 Changed 5 years ago by macports.mails.skeeve@…

No. Up to now I was satisfied with the XCode gcc. But since I want to compile something using a data member in a vector I figured out I need some newer version than 4.2. So I tried MacPorts.

comment:8 in reply to:  6 Changed 5 years ago by potmj

Replying to larryv@…:

Has duplicate #46068.

Have any of you been able to build GCC 4.9.2 in the past?

I got here from a dependency from trying to upgrade something else, so it's been a while since this was last compiled.......

% port installed libgcc
The following ports are currently installed:
  libgcc @4.8.2_0
  libgcc @4.8.2_2 (active)
Last edited 5 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:9 Changed 5 years ago by larryv (Lawrence Velázquez)

I just set up an x86_64 VM running 10.5.8 Server and can reproduce the failure.

Last edited 5 years ago by larryv (Lawrence Velázquez) (previous) (diff)

comment:10 Changed 5 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: assignedclosed

Duplicate of #44667.

comment:11 Changed 5 years ago by keloin@…

Cc: keloin@… added

Cc Me!

Note: See TracTickets for help on using tickets.