Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#46030 closed submission (fixed)

octave-mechanics 1.3.1

Reported by: Schamschula (Marius Schamschula) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: kurthindenburg (Kurt Hindenburg), michaelld (Michael Dickens)
Port: octave-mechanics

Description

I've added a port ofoctave-mechanics 1.3.1.

Library with functions useful for numerical computation in classical mechanics and structural analysis.

Attachments (1)

Portfile (876 bytes) - added by Schamschula (Marius Schamschula) 5 years ago.

Download all attachments as: .zip

Change History (14)

Changed 5 years ago by Schamschula (Marius Schamschula)

Attachment: Portfile added

comment:1 Changed 5 years ago by mf2k (Frank Schima)

Keywords: haspatch maintainer removed
Version: 2.3.3

comment:2 Changed 5 years ago by kurthindenburg (Kurt Hindenburg)

Cc: khindenburg@… added

Cc Me!

comment:3 Changed 5 years ago by kurthindenburg (Kurt Hindenburg)

I can't get the dependencies to build - do you have octave 4.0+ installed? I have octave 3.8

error: the following dependencies were unsatisfied:
   linear-algebra needs octave >= 4.0.0
Command failed: /opt/local/bin/octave -q -f --eval 'pkg prefix /opt/local/share/octave/packages /opt/local/lib/octave/packages; pkg install -verbose
-global /opt/local/share/octave/linear-algebra.tar.gz'
Exit code: 1
Error: Failed to activate octave-linear-algebra: command execution failed

comment:4 Changed 5 years ago by Schamschula (Marius Schamschula)

Nope. When I first built octave-mechanics 1.3.1 last November, I was running standard MP octave 3.8.2 under Mavericks. Yesterday, I rebuilt octave-mechanics under octave @3.8.2_7+atlas+gcc49+glgui+gui+metis+qtgui on a freshly updated machine running Yosemite.

comment:5 Changed 5 years ago by kurthindenburg (Kurt Hindenburg)

very strange - not sure what's going on

error: the following dependencies were unsatisfied:
   mechanics needs linear-algebra >= 2.0.0
The following ports are currently installed:
  octave-linear-algebra @2.2.2_0 (active)

comment:6 Changed 5 years ago by Schamschula (Marius Schamschula)

I think the problem is with octave-linear-algebra @2.2.2_0.

In order to get that installed octave-mechanics, I had to manually downgrade back to @2.2.1_0

I'm not sure how Michael D. got @2.2.2_0 to build before he committed https://trac.macports.org/changeset/134755

comment:7 Changed 5 years ago by kurthindenburg (Kurt Hindenburg)

Cc: michaelld@… added

Michaell, how did you get octave-linear-algebra @2.2.2 to build?

comment:8 Changed 5 years ago by michaelld (Michael Dickens)

o-l-a 2.2.2 just built for me nicely. I'm running 10.8. One of the buildbots caught a strange linking issue with the Fortran libraries, but I'm not sure if that makes any real difference. Looking at the NEWS for this archive:

% more NEWS 
Summary of important user-visible changes for linear-algebra 2.2.2:
-------------------------------------------------------------------

** Several functions have been adapted to the new core-Octave "ismatrix"
   behavior (the latter only checks for 2D size, not class). To this
   end all input matrices are checked against the "isnumeric" function.
   The linear-algebra package is expected to still work for older Octave
   versions than 4.0.0 as this "isnumeric" check is only additional.

** nmf_* functions use inputParser from Octave 4.0.0. They won't work
   with older versions. 

** The interface of mnf_bpas has been simplified. The option 'verbose' 
   is now a swtich and it doesn't require a value. The History of the
   calculations IS stored and returned only if the 4th output argument 
   is requested.

So, this version should still work with our current Octave 3.8.2.

Last edited 5 years ago by michaelld (Michael Dickens) (previous) (diff)

comment:9 Changed 5 years ago by michaelld (Michael Dickens)

It is interesting that in the top-level DESCRIPTION file, there is this little item:

Depends: octave (>= 4.0.0)

so ... I don't think it should be building using Octave 3.8.2. That's an easy patch, of course ;)

comment:10 Changed 5 years ago by michaelld (Michael Dickens)

OK; yeah. Something is going on. OLA builds for me, but after installing it does not load.

comment:11 Changed 5 years ago by michaelld (Michael Dickens)

I just pushed r134952, which fixes OLA to work for me on Octave 3.8.2 and OSX 10.8. "pkg load" now works too, so hopefully OLA will now be available for any other Octave-* ports that need to depend on it.

comment:12 Changed 5 years ago by kurthindenburg (Kurt Hindenburg)

Resolution: fixed
Status: newclosed

Thanks - side note, I typically use -t (trace) and all the other octave-* work fine - it fails building ola (ld: library not found for -lgfortran) - works fine w/o -t

done r134954

comment:13 Changed 5 years ago by michaelld (Michael Dickens)

Thanks for that note on OLA. I think it needs access to GCC libraries, which won't stay around in trace mode. I'll look into this next week.

Note: See TracTickets for help on using tickets.